summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-15 07:18:41 +0100
committerRemi Collet <remi@remirepo.net>2017-12-15 07:18:41 +0100
commit997d041157c810f6aae1132fcef3a037fa04b26e (patch)
tree70ff8e0c79907c8bdfcbd12cf125b82c698c6028
parent98088da8115e96ab0bfe1b081d2dab2f929ec9f6 (diff)
v1.6.4 from Fedora
-rw-r--r--composer.json3
-rw-r--r--php-erusev-parsedown.spec13
2 files changed, 11 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 28145af..b7f8aea 100644
--- a/composer.json
+++ b/composer.json
@@ -15,6 +15,9 @@
"require": {
"php": ">=5.3.0"
},
+ "require-dev": {
+ "phpunit/phpunit": "^4.8.35"
+ },
"autoload": {
"psr-0": {"Parsedown": ""}
}
diff --git a/php-erusev-parsedown.spec b/php-erusev-parsedown.spec
index 2bccca9..171a982 100644
--- a/php-erusev-parsedown.spec
+++ b/php-erusev-parsedown.spec
@@ -12,8 +12,8 @@
%global github_owner erusev
%global github_name parsedown
-%global github_version 1.6.3
-%global github_commit 728952b90a333b5c6f77f06ea9422b94b585878d
+%global github_version 1.6.4
+%global github_commit fbe3fe878f4fe69048bb8a52783a09802004f548
%global composer_vendor erusev
%global composer_project parsedown
@@ -45,8 +45,8 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 1.6.3)
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
+## phpcompatinfo (computed from version 1.6.4)
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -56,7 +56,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.6.3)
+# phpcompatinfo (computed from version 1.6.4)
Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
@@ -126,6 +126,9 @@ exit $RETURN_CODE
%changelog
+* Thu Dec 14 2017 Shawn Iwinski <shawn@iwin.ski> - 1.6.4-1
+- Update to 1.6.4 (RHBZ #1513209)
+
* Sat Jul 08 2017 Shawn Iwinski <shawn@iwin.ski> - 1.6.3-1
- Update to 1.6.3 (RHBZ #1468067)
- Add "get source" script because upstream attributes removed tests from snapshot