summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-01 15:10:11 +0200
committerRemi Collet <remi@remirepo.net>2020-07-01 15:10:11 +0200
commit8d41c7241006976f793010dd7518baccb1d17eb5 (patch)
tree98ba76520914a12413275391e8986754de41b75a
parentcc768ea027f3005ae4d0368bb96945c895db962d (diff)
update to 2.0.2HEADmaster
-rw-r--r--composer.json6
-rw-r--r--php-elvanto-litemoji.spec20
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 2b8deef..ab4fe01 100644
--- a/composer.json
+++ b/composer.json
@@ -9,18 +9,18 @@
},
"require-dev": {
"phpunit/phpunit": "^5.0",
- "milesj/emojibase": "4.0.0"
+ "milesj/emojibase": "5.0.1"
},
"repositories": [
{
"type": "package",
"package": {
"name": "milesj/emojibase",
- "version": "4.0.0",
+ "version": "5.0.1",
"source": {
"url": "https://github.com/milesj/emojibase",
"type": "git",
- "reference": "tags/emojibase-data@4.0.0"
+ "reference": "tags/emojibase-data@5.0.1"
}
}
}
diff --git a/php-elvanto-litemoji.spec b/php-elvanto-litemoji.spec
index ba7fcd6..0f262f6 100644
--- a/php-elvanto-litemoji.spec
+++ b/php-elvanto-litemoji.spec
@@ -1,20 +1,21 @@
# remirepo/fedora spec file for php-elvanto-litemoji
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 2cba2c87c505fe1d3a6e06ff4cc48d98af757521
+%global gh_commit a71f785642a93194d0b88edebcc5d6ca0b07d282
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner elvanto
%global gh_project litemoji
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%global ns_project LitEmoji
+
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Conversion of unicode, HTML and shortcode emoji
@@ -23,14 +24,14 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 5.6
BuildRequires: php-mbstring
BuildRequires: php-pcre
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^5.0",
-# "milesj/emojibase": "4.0.0"
+# "milesj/emojibase": "5.0.1"
%global phpunit %{_bindir}/phpunit
BuildRequires: php-phpunit-PHPUnit >= 5.0
# Autoloader
@@ -76,9 +77,9 @@ cp -pr src %{buildroot}%{_datadir}/php/%{ns_project}
%check
-%if %{with_tests}
+%if %{with tests}
ret=0
-for cmd in php php56 php70 php71 php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd %{phpunit} \
--bootstrap %{buildroot}%{_datadir}/php/%{ns_project}/autoload.php \
@@ -101,6 +102,9 @@ exit $ret
%changelog
+* Wed Jul 1 2020 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+
* Thu Jul 25 2019 Remi Collet <remi@remirepo.net> - 2.0.1-1
- update to 2.0.1