summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json31
-rw-r--r--php-egulias-email-validator.spec9
2 files changed, 37 insertions, 3 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f346216
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,31 @@
+{
+ "name": "egulias/email-validator",
+ "description": "A library for validating emails",
+ "homepage": "https://github.com/egulias/EmailValidator",
+ "type": "Library",
+ "keywords": ["email", "validation", "validator", "emailvalidation", "emailvalidator"],
+ "license": "MIT",
+ "authors": [
+ {"name": "Eduardo Gulias Davis"}
+ ],
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.0.x-dev"
+ }
+ },
+ "require": {
+ "php": ">= 5.3.3",
+ "doctrine/lexer": "^1.0.1"
+ },
+ "require-dev" : {
+ "phpunit/phpunit": "^4.8.24"
+ },
+ "autoload": {
+ "psr-0": {
+ "Egulias\\": "src/"
+ }
+ },
+ "scripts": {
+ "test": "phpunit"
+ }
+}
diff --git a/php-egulias-email-validator.spec b/php-egulias-email-validator.spec
index 9d06315..392bfce 100644
--- a/php-egulias-email-validator.spec
+++ b/php-egulias-email-validator.spec
@@ -12,8 +12,8 @@
%global github_owner egulias
%global github_name EmailValidator
-%global github_version 1.2.14
-%global github_commit 5642614492f0ca2064c01d60cc33284cc2f731a9
+%global github_version 1.2.15
+%global github_commit 758a77525bdaabd6c0f5669176bd4361cb2dda9e
%global composer_vendor egulias
%global composer_project email-validator
@@ -123,7 +123,7 @@ sed -e 's/function testValidEmailsWithWarningsCheck/function SKIP_testValidEmail
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose \
--bootstrap %{buildroot}%{phpdir}/Egulias/EmailValidator/autoload.php \
@@ -146,6 +146,9 @@ exit $RETURN_CODE
%changelog
+* Wed Sep 26 2018 Remi Collet <remi@remirepo.net> - 1.2.15-1
+- update to 1.2.15
+
* Tue Apr 24 2018 Remi Collet <remi@remirepo.net> - 1.2.14-1
- update to 1.2.14
- use range dependencies (F27+, EL-8)