summaryrefslogtreecommitdiffstats
path: root/php-egulias-email-validator.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-06 07:20:26 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-06 07:20:26 +0100
commitacf4c8ff630cad4e7e44946719bef617572dabdf (patch)
tree76103f764edd1174578b75b2d8308b2b4e814b62 /php-egulias-email-validator.spec
php-egulias-email-validator: import from rawhide
Diffstat (limited to 'php-egulias-email-validator.spec')
-rw-r--r--php-egulias-email-validator.spec126
1 files changed, 126 insertions, 0 deletions
diff --git a/php-egulias-email-validator.spec b/php-egulias-email-validator.spec
new file mode 100644
index 0000000..6aa24a3
--- /dev/null
+++ b/php-egulias-email-validator.spec
@@ -0,0 +1,126 @@
+#
+# RPM spec file for php-egulias-email-validator
+#
+# Copyright (c) 2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner egulias
+%global github_name EmailValidator
+%global github_version 1.2.4
+%global github_commit 5c3a79217cbb98c975d7d23f12749e6f0be5cace
+
+%global composer_vendor egulias
+%global composer_project email-validator
+
+# "php": ">= 5.3.3"
+%global php_min_ver 5.3.3
+# "doctrine/lexer": "~1.0"
+%global doctrine_lexer_min_ver 1.0
+%global doctrine_lexer_max_ver 2.0
+
+# Build using "--without tests" to disable tests
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+%{!?__phpunit: %global __phpunit %{_bindir}/phpunit}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: A library for validating emails
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php-phpunit-PHPUnit
+# composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(doctrine/lexer) >= %{doctrine_lexer_min_ver}
+BuildRequires: php-composer(doctrine/lexer) < %{doctrine_lexer_max_ver}
+# phpcompatinfo (computed from version 1.2.4)
+BuildRequires: php-filter
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+Requires: php-composer(doctrine/lexer) >= %{doctrine_lexer_min_ver}
+Requires: php-composer(doctrine/lexer) < %{doctrine_lexer_max_ver}
+# phpcompatinfo (computed from version 1.2.4)
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+%{summary}.
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+# W: wrong-file-end-of-line-encoding /usr/share/doc/php-egulias-email-validator/README.md
+sed -i 's/\r$//' README.md
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -pm 0755 %{buildroot}%{phpdir}
+cp -rp src/* %{buildroot}%{phpdir}/
+
+
+%check
+%if %{with_tests}
+# Create autoloader
+mkdir vendor
+cat > vendor/autoload.php <<'AUTOLOAD'
+<?php
+
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', $class).'.php';
+ @include_once $src;
+});
+AUTOLOAD
+
+# Create PHPUnit config with colors turned off
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
+
+%{__phpunit} --include-path %{buildroot}%{phpdir} -d date.timezone="UTC"
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json
+%dir %{phpdir}/Egulias
+ %{phpdir}/Egulias/EmailValidator
+
+
+%changelog
+* Mon Nov 03 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.4-1
+- Updated to 1.2.4
+
+* Mon Oct 27 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.3-1
+- Updated to 1.2.3
+
+* Wed Sep 10 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.2-1
+- Initial package