summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--php-echonest-api.spec28
2 files changed, 32 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-echonest-api.spec b/php-echonest-api.spec
index a2cc85b..f4017e0 100644
--- a/php-echonest-api.spec
+++ b/php-echonest-api.spec
@@ -1,3 +1,12 @@
+# remirepo spec file for php-echonest-api, from:
+#
+# Fedora spec file for php-echonest-api
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
%global commit 662d62a7df1247515572bf517e14b795714e0824
%global short_commit %(echo %{commit} | cut -c 1-8)
@@ -48,16 +57,35 @@ install -p -m 0644 %{S:1} %{buildroot}/%{_datadir}/php/EchoNest
%check
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --bootstrap %{buildroot}/%{_datadir}/php/EchoNest/autoload.php || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --bootstrap %{buildroot}/%{_datadir}/php/EchoNest/autoload.php || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
phpunit --bootstrap=%{buildroot}/%{_datadir}/php/EchoNest/autoload.php
+# remirepo:2
+fi
+exit $ret
%files
+%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md
%{_datadir}/php/EchoNest
%changelog
+* Tue Jan 24 2017 Remi Collet <remi@remirepo.net> - 0-0.3.20131228git.662d62a7
+- backport for remi repo
+
* Sat Jan 21 2017 Randy Barlow <bowlofeggs@fedoraproject.org> - 0-0.3.20131228git.662d62a7
- Add the commit date into the release.
- Remove the execute bit on php files.