summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-20 09:17:59 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-20 09:17:59 +0100
commitf9dd496ee31877c803542f524b9f0f6f47786bb3 (patch)
tree066a7ced7e33d3185cfa3df3f9a885fb66529a0e
parenta2173f5a2d8022095c28f60aa04d61bd84ea33f5 (diff)
php-drush-drush: backport for remi repo
-rw-r--r--Makefile10
-rw-r--r--php-drush-drush.spec5
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-drush-drush.spec b/php-drush-drush.spec
index 301acd9..8e56ae4 100644
--- a/php-drush-drush.spec
+++ b/php-drush-drush.spec
@@ -29,6 +29,7 @@ Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Provides: drupal6-drush = %{version}-%{release}
Obsoletes: drupal6-drush < %{version}-%{release}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
@@ -172,6 +173,7 @@ fi
%files
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%doc %{_mandir}/man1/drush.1*
%{pear_xmldir}/%{name}.xml
@@ -181,6 +183,9 @@ fi
%changelog
+* Wed Mar 20 2013 Remi Collet <remi@fedoraproject.org> 5.8.0-2
+- backport 5.8.0 for remi repo.
+
* Sun Mar 17 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 5.8.0-2
- Removed drush.bat
- Fixed rpmlint wrong-file-end-of-line-encoding warning