summaryrefslogtreecommitdiffstats
path: root/php-doctrine-sql-formatter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-sql-formatter.spec')
-rw-r--r--php-doctrine-sql-formatter.spec131
1 files changed, 131 insertions, 0 deletions
diff --git a/php-doctrine-sql-formatter.spec b/php-doctrine-sql-formatter.spec
new file mode 100644
index 0000000..f5ed1c3
--- /dev/null
+++ b/php-doctrine-sql-formatter.spec
@@ -0,0 +1,131 @@
+# remirepo/fedora spec file for php-doctrine-sql-formatter
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%global bootstrap 0
+%global gh_commit 1ad4f97f10cd0eef7ca7d3f5b7b1cf7e5806786f
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner doctrine
+%global gh_project sql-formatter
+%global major %nil
+# packagist
+%global pk_vendor %{gh_owner}
+%global pk_project %{gh_project}
+# Namespace
+%global ns_vendor Doctrine
+%global ns_project SqlFormatter
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 1.1.1
+Release: 1%{?dist}
+Summary: SQL highlighting library
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+BuildRequires: php(language) >= 7.1
+BuildRequires: php-pcre
+# From composer.json
+# "bamarni/composer-bin-plugin": "^1.4"
+BuildRequires: phpunit8
+%endif
+
+# From composer.json
+# "php": "^7.1"
+Requires: php(language) >= 7.1
+# From phpcompatinfo report for version 1.0.1
+Requires: php-pcre
+
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+A lightweight php package for formatting sql statements.
+
+It can automatically indent and add line breaks in addition to syntax
+highlighting.
+
+This package is a fork from jdorn/sql-formatter.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate a simple autoloader
+%{_bindir}/phpab \
+ --output src/autoload.php \
+ --template fedora \
+ src
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+: Generate autoloader
+mkdir vendor
+%{_bindir}/phpab \
+ --output vendor/autoload.php \
+ --template fedora \
+ tests
+
+cat << 'EOF' | tee -a vendor/autoload.php
+require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php";
+EOF
+
+: Run test suite
+ret=0
+for cmd in php php72 php73 php74 php80; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit8 \
+ --bootstrap vendor/autoload.php \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.txt
+%doc *.md
+%doc composer.json
+%dir %{_datadir}/php/%{ns_vendor}
+ %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- initial package, version 1.0.1