summaryrefslogtreecommitdiffstats
path: root/php-doctrine-reflection.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-reflection.spec')
-rw-r--r--php-doctrine-reflection.spec27
1 files changed, 14 insertions, 13 deletions
diff --git a/php-doctrine-reflection.spec b/php-doctrine-reflection.spec
index 3e99b7a..a2d377f 100644
--- a/php-doctrine-reflection.spec
+++ b/php-doctrine-reflection.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-reflection
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2018-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit 02538d3f95e88eb397a5f86274deb2c6175c2ab6
+%global gh_commit bc420ead87fdfe08c03ecc3549db603a45b06d4c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project reflection
@@ -26,11 +26,10 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.0.0
-Release: 2%{?dist}
+Version: 1.1.0
+Release: 1%{?dist}
Summary: Additional reflection functionality
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
@@ -45,22 +44,21 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tokenizer
# From composer.json
-# "phpstan/phpstan": "^0.9.2",
-# "phpstan/phpstan-phpunit": "^0.9.4",
+# "phpstan/phpstan": "^0.11.0",
+# "phpstan/phpstan-phpunit": "^0.11.0",
# "phpunit/phpunit": "^7.0",
-# "doctrine/coding-standard": "^4.0",
-# "doctrine/common": "^2.8",
-# "squizlabs/php_codesniffer": "^3.0"
+# "doctrine/coding-standard": "^5.0",
+# "doctrine/common": "^2.10"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
-BuildRequires: (php-composer(doctrine/common) >= 2.8 with php-composer(doctrine/common) < 3)
+BuildRequires: (php-composer(doctrine/common) >= 2.10 with php-composer(doctrine/common) < 3)
# remirepo:6
%else
BuildRequires: php-composer(doctrine/annotations) < 2
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(doctrine/common) < 3
-BuildRequires: php-composer(doctrine/common) >= 2.8
+BuildRequires: php-composer(doctrine/common) >= 2.10
%endif
BuildRequires: phpunit7
%endif
@@ -142,7 +140,7 @@ find tests -type f -exec grep -q PHPStan {} \; -delete -print
: Run test suite
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit7 \
--bootstrap vendor/autoload.php \
@@ -164,6 +162,9 @@ exit $ret
%changelog
+* Thu Jan 9 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Thu Nov 22 2018 Remi Collet <remi@remirepo.net> - 1.0.0-2
- fix conflicts