summaryrefslogtreecommitdiffstats
path: root/php-doctrine-reflection.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-reflection.spec')
-rw-r--r--php-doctrine-reflection.spec43
1 files changed, 19 insertions, 24 deletions
diff --git a/php-doctrine-reflection.spec b/php-doctrine-reflection.spec
index df94df0..eb4f3f8 100644
--- a/php-doctrine-reflection.spec
+++ b/php-doctrine-reflection.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-reflection
#
-# Copyright (c) 2018-2020 Remi Collet
+# Copyright (c) 2018-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit fa587178be682efe90d005e3a322590d6ebb59a5
+%global gh_commit 1034e5e71f89978b80f9c1570e7226f6c3b9b6fb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project reflection
@@ -26,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.2.2
+Version: 1.2.3
Release: 1%{?dist}
Summary: Additional reflection functionality
@@ -44,29 +44,22 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tokenizer
# From composer.json
-# "doctrine/coding-standard": "^6.0 || ^8.2.0",
-# "doctrine/common": "^2.10",
-# "phpstan/phpstan": "^0.11.0 || ^0.12.20",
-# "phpstan/phpstan-phpunit": "^0.11.0 || ^0.12.16",
-# "phpunit/phpunit": "^7.5 || ^9.1.5"
+# "doctrine/coding-standard": "^9",
+# "doctrine/common": "^3.3",
+# "phpstan/phpstan": "^1.4.10",
+# "phpstan/phpstan-phpunit": "^1",
+# "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
-BuildRequires: (php-composer(doctrine/common) >= 2.10 with php-composer(doctrine/common) < 3)
-# remirepo:6
+BuildRequires: (php-composer(doctrine/common) >= 3.3 with php-composer(doctrine/common) < 4)
+# remirepo:4
%else
-BuildRequires: php-composer(doctrine/annotations) < 2
-BuildRequires: php-composer(doctrine/annotations) >= 1.0
-BuildRequires: php-composer(doctrine/common) < 3
-BuildRequires: php-composer(doctrine/common) >= 2.10
+BuildRequires: php-doctrine-annotations >= 1.0
+BuildRequires: php-doctrine-common3 >= 3.3
%endif
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.1.5
-%else
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5
-%endif
+BuildRequires: phpunit9 >= 9.5
%endif
# From composer.json
@@ -76,10 +69,9 @@ Requires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
-# remirepo:4
+# remirepo:3
%else
-Requires: php-composer(doctrine/annotations) < 2
-Requires: php-composer(doctrine/annotations) >= 1.0
+Requires: php-doctrine-annotations >= 1.0
%endif
# From phpcompatinfo report for version 1.0.0
Requires: php-reflection
@@ -138,7 +130,7 @@ mkdir vendor
cat << 'EOF' | tee -a vendor/autoload.php
require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/%{ns_subproj}/autoload.php";
-require "%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php";
+require "%{_datadir}/php/%{ns_vendor}/%{ns_project}3/autoload.php";
EOF
# we don't want PHPStan (which pull nette framework)
@@ -169,6 +161,9 @@ exit $ret
%changelog
+* Wed Jun 1 2022 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+
* Wed Oct 28 2020 Remi Collet <remi@remirepo.net> - 1.2.2-1
- update to 1.2.2
- switch to phpunit9