summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-28 08:24:19 +0100
committerRemi Collet <remi@remirepo.net>2020-10-28 08:24:19 +0100
commit03a7d6a8b4f4f1684d1813bab3e66a583a40a641 (patch)
tree5376c70d42fa139dde97a065d78f79ce4a93c6ef
parentabd4088d144ba4f34ea9e5960fd912dc7b756f87 (diff)
update to 1.2.2
switch to phpunit9
-rw-r--r--composer.json15
-rw-r--r--php-doctrine-reflection.spec35
2 files changed, 32 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index ee53a03..39601dd 100644
--- a/composer.json
+++ b/composer.json
@@ -17,16 +17,16 @@
{"name": "Marco Pivetta", "email": "ocramius@gmail.com"}
],
"require": {
- "php": "^7.1",
+ "php": "^7.1 || ^8.0",
"ext-tokenizer": "*",
"doctrine/annotations": "^1.0"
},
"require-dev": {
- "phpstan/phpstan": "^0.11.0",
- "phpstan/phpstan-phpunit": "^0.11.0",
- "phpunit/phpunit": "^7.0",
- "doctrine/coding-standard": "^5.0",
- "doctrine/common": "^2.10"
+ "doctrine/coding-standard": "^6.0 || ^8.2.0",
+ "doctrine/common": "^2.10",
+ "phpstan/phpstan": "^0.11.0 || ^0.12.20",
+ "phpstan/phpstan-phpunit": "^0.11.0 || ^0.12.16",
+ "phpunit/phpunit": "^7.5 || ^9.1.5"
},
"conflict": {
"doctrine/common": "<2.9"
@@ -42,6 +42,9 @@
"Doctrine\\Tests_PHP74\\": "tests/Doctrine/Tests_PHP74"
}
},
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
"dev-master": "1.2.x-dev"
diff --git a/php-doctrine-reflection.spec b/php-doctrine-reflection.spec
index 5929fc1..df94df0 100644
--- a/php-doctrine-reflection.spec
+++ b/php-doctrine-reflection.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit 55e71912dfcd824b2fdd16f2d9afe15684cfce79
+%global gh_commit fa587178be682efe90d005e3a322590d6ebb59a5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project reflection
@@ -26,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}
Summary: Additional reflection functionality
@@ -44,11 +44,11 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tokenizer
# From composer.json
-# "phpstan/phpstan": "^0.11.0",
-# "phpstan/phpstan-phpunit": "^0.11.0",
-# "phpunit/phpunit": "^7.0",
-# "doctrine/coding-standard": "^5.0",
-# "doctrine/common": "^2.10"
+# "doctrine/coding-standard": "^6.0 || ^8.2.0",
+# "doctrine/common": "^2.10",
+# "phpstan/phpstan": "^0.11.0 || ^0.12.20",
+# "phpstan/phpstan-phpunit": "^0.11.0 || ^0.12.16",
+# "phpunit/phpunit": "^7.5 || ^9.1.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
@@ -60,11 +60,17 @@ BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(doctrine/common) < 3
BuildRequires: php-composer(doctrine/common) >= 2.10
%endif
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.1.5
+%else
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.5
+%endif
%endif
# From composer.json
-# "php": "^7.1"
+# "php": "^7.1 || ^8.0"
# "doctrine/annotations": "^1.0"
Requires: php(language) >= 7.1
# remirepo:1
@@ -140,9 +146,10 @@ find tests -type f -exec grep -q PHPStan {} \; -delete -print
: Run test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
--bootstrap vendor/autoload.php \
--verbose || ret=1
fi
@@ -162,6 +169,10 @@ exit $ret
%changelog
+* Wed Oct 28 2020 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+- switch to phpunit9
+
* Fri Mar 27 2020 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1