summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 10:09:23 +0100
committerRemi Collet <remi@php.net>2022-12-20 10:09:23 +0100
commiteaca1949c651c35e5e0e2cc1bc325df57cd6cd38 (patch)
treed4d583d3f1a446fbe4484539945ec4023cd81ec6
parent90ee57d063e164252c532de6e745a5c5e74a04c8 (diff)
update to 3.1.2
-rw-r--r--composer.json8
-rw-r--r--php-doctrine-persistence3.spec14
2 files changed, 10 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 3dbf70e..1c4633f 100644
--- a/composer.json
+++ b/composer.json
@@ -26,18 +26,16 @@
},
"require-dev": {
"composer/package-versions-deprecated": "^1.11",
- "phpstan/phpstan": "1.8.8",
+ "phpstan/phpstan": "1.9.4",
"phpstan/phpstan-phpunit": "^1",
"phpstan/phpstan-strict-rules": "^1.1",
- "doctrine/annotations": "^1.7",
- "doctrine/coding-standard": "^10",
+ "doctrine/coding-standard": "^11",
"doctrine/common": "^3.0",
"phpunit/phpunit": "^8.5 || ^9.5",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
- "vimeo/psalm": "4.29.0"
+ "vimeo/psalm": "4.30.0 || 5.3.0"
},
"conflict": {
- "doctrine/annotations": "<1.7 || >=2.0",
"doctrine/common": "<2.10"
},
"autoload": {
diff --git a/php-doctrine-persistence3.spec b/php-doctrine-persistence3.spec
index f660f4f..0403b2c 100644
--- a/php-doctrine-persistence3.spec
+++ b/php-doctrine-persistence3.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit d87426f07dd66f97cfdcf5210925e483b6c993b5
+%global gh_commit b44d128311af55275dbed6a4558ca59a2b9f9387
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project persistence
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.1.1
+Version: 3.1.2
Release: 1%{?dist}
Summary: Doctrine Persistence abstractions, version %{major}
@@ -48,7 +48,6 @@ BuildRequires: php-spl
# "phpstan/phpstan": "1.8.8",
# "phpstan/phpstan-phpunit": "^1",
# "phpstan/phpstan-strict-rules": "^1.1",
-# "doctrine/annotations": "^1.7",
# "doctrine/coding-standard": "^10",
# "doctrine/common": "^3.0",
# "phpunit/phpunit": "^8.5 || ^9.5",
@@ -56,14 +55,12 @@ BuildRequires: php-spl
# "vimeo/psalm": "4.29.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(doctrine/annotations) >= 1.7 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-composer(doctrine/event-manager) >= 1 with php-composer(doctrine/event-manager) < 3)
BuildRequires: (php-composer(doctrine/common) >= 3.0 with php-composer(doctrine/common) < 4)
BuildRequires: (php-composer(symfony/cache) >= 4.4 with php-composer(symfony/cache) < 7)
BuildRequires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
-# remirepo:7
+# remirepo:6
%else
-BuildRequires: php-doctrine-annotations >= 1.7
BuildRequires: php-doctrine-event-manager >= 1.0
BuildRequires: php-doctrine-common3 >= 3.0
BuildRequires: php-symfony4-cache >= 4.4
@@ -121,6 +118,7 @@ mv src/%{ns_subproj} \
--output src/%{ns_subproj}%{major}/autoload.php \
--template fedora \
src
+
cat << 'EOF' | tee -a src/%{ns_subproj}%{major}/autoload.php
// Dependencies
@@ -152,7 +150,6 @@ cat << 'EOF' | tee -a vendor/autoload.php
require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_subproj}%{major}/autoload.php";
\Fedora\Autoloader\Dependencies::required([
'%{_datadir}/php/%{ns_vendor}/Common3/autoload.php',
- '%{_datadir}/php/%{ns_vendor}/%{ns_project}/Annotations/autoload.php',
[
'%{_datadir}/php/Symfony6/Component/Cache/autoload.php',
'%{_datadir}/php/Symfony5/Component/Cache/autoload.php',
@@ -190,6 +187,9 @@ exit $ret
%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
* Wed Dec 14 2022 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1