summaryrefslogtreecommitdiffstats
path: root/php-doctrine-persistence2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-26 07:18:08 +0100
committerRemi Collet <remi@remirepo.net>2020-10-26 07:18:08 +0100
commitf9024361ae282412e6938d9c0ed2aabe46006ce3 (patch)
treef63d6c80c51a1fa46715a10b483a5a8d78a002ba /php-doctrine-persistence2.spec
parent724ed7313924f2a7e76a1ca767fa68e73bf389da (diff)
update to 2.1.0
switch to phpunit9
Diffstat (limited to 'php-doctrine-persistence2.spec')
-rw-r--r--php-doctrine-persistence2.spec66
1 files changed, 34 insertions, 32 deletions
diff --git a/php-doctrine-persistence2.spec b/php-doctrine-persistence2.spec
index 345a413..545d453 100644
--- a/php-doctrine-persistence2.spec
+++ b/php-doctrine-persistence2.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit 1dee036f22cd5dc0bc12132f1d1c38415907be55
+%global gh_commit 3bc796882c9f69526b7833b46ba3cd0c06b0460f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project persistence
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
+Version: 2.1.0
Release: 1%{?dist}
Summary: Doctrine Persistence abstractions
@@ -44,9 +44,10 @@ BuildRequires: php-reflection
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json
-# "phpstan/phpstan": "^0.11",
-# "doctrine/coding-standard": "^6.0",
-# "phpunit/phpunit": "^7.0",
+# "composer/package-versions-deprecated": "^1.11",
+# "phpstan/phpstan": "^0.12",
+# "doctrine/coding-standard": "^6.0 || ^8.0",
+# "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0",
# "vimeo/psalm": "^3.11"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -55,24 +56,25 @@ BuildRequires: (php-composer(doctrine/cache) >= 1.0 with php-composer(
BuildRequires: (php-composer(doctrine/collections) >= 1.0 with php-composer(doctrine/collections) < 2)
BuildRequires: (php-composer(doctrine/event-manager) >= 1.0 with php-composer(doctrine/event-manager) < 2)
BuildRequires: (php-composer(doctrine/reflection) >= 1.2 with php-composer(doctrine/reflection) < 2)
-# remirepo:12
+# remirepo:7
%else
-BuildRequires: php-composer(doctrine/annotations) < 2
-BuildRequires: php-composer(doctrine/annotations) >= 1.0
-BuildRequires: php-composer(doctrine/cache) < 2
-BuildRequires: php-composer(doctrine/cache) >= 1.0
-BuildRequires: php-composer(doctrine/collections) < 2
-BuildRequires: php-composer(doctrine/collections) >= 1.0
-BuildRequires: php-composer(doctrine/event-manager) < 2
-BuildRequires: php-composer(doctrine/event-manager) >= 1.0
-BuildRequires: php-composer(doctrine/reflection) < 2
-BuildRequires: php-composer(doctrine/reflection) >= 1.2
+BuildRequires: php-doctrine-annotations >= 1.0
+BuildRequires: php-doctrine-cache >= 1.0
+BuildRequires: php-doctrine-collections >= 1.0
+BuildRequires: php-doctrine-event-manager >= 1.0
+BuildRequires: php-doctrine-reflection >= 1.2
+%endif
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
+%else
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8
%endif
-BuildRequires: phpunit7
%endif
# From composer.json
-# "php": "^7.1"
+# "php": "^7.1 || ^8.0"
# "doctrine/annotations": "^1.0",
# "doctrine/cache": "^1.0",
# "doctrine/collections": "^1.0",
@@ -86,18 +88,13 @@ Requires: (php-composer(doctrine/cache) >= 1.0 with php-composer(
Requires: (php-composer(doctrine/collections) >= 1.0 with php-composer(doctrine/collections) < 2)
Requires: (php-composer(doctrine/event-manager) >= 1.0 with php-composer(doctrine/event-manager) < 2)
Requires: (php-composer(doctrine/reflection) >= 1.2 with php-composer(doctrine/reflection) < 2)
-# remirepo:12
+# remirepo:7
%else
-Requires: php-composer(doctrine/annotations) < 2
-Requires: php-composer(doctrine/annotations) >= 1.0
-Requires: php-composer(doctrine/cache) < 2
-Requires: php-composer(doctrine/cache) >= 1.0
-Requires: php-composer(doctrine/collections) < 2
-Requires: php-composer(doctrine/collections) >= 1.0
-Requires: php-composer(doctrine/event-manager) < 2
-Requires: php-composer(doctrine/event-manager) >= 1.0
-Requires: php-composer(doctrine/reflection) < 2
-Requires: php-composer(doctrine/reflection) >= 1.2
+Requires: php-doctrine-annotations >= 1.0
+Requires: php-doctrine-cache >= 1.0
+Requires: php-doctrine-collections >= 1.0
+Requires: php-doctrine-event-manager >= 1.0
+Requires: php-doctrine-reflection >= 1.2
%endif
# From phpcompatinfo report for version 1.0.0
Requires: php-reflection
@@ -170,9 +167,10 @@ find tests -type f -exec grep -q PHPStan {} \; -delete -print
: Run test suite
ret=0
-for cmd in php php72 php73 php74 php80; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
--bootstrap vendor/autoload.php \
--verbose || ret=1
fi
@@ -193,6 +191,10 @@ exit $ret
%changelog
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+- switch to phpunit9
+
* Thu May 14 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- rename to php-doctrine-persistence2