summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-doctrine-orm-upstream.patch2
-rw-r--r--php-doctrine-orm.spec7
2 files changed, 6 insertions, 3 deletions
diff --git a/php-doctrine-orm-upstream.patch b/php-doctrine-orm-upstream.patch
index c8d6170..b2dff4c 100644
--- a/php-doctrine-orm-upstream.patch
+++ b/php-doctrine-orm-upstream.patch
@@ -49,7 +49,7 @@ index 5d36f64..f8b4bb7 100644
public function newInstance()
{
- if ($this->_prototype === null) {
-- if (PHP_VERSION_ID === 50429 || PHP_VERSION_ID === 50513) {
+- if (PHP_VERSION_ID === 50429 || PHP_VERSION_ID === 50513 || PHP_VERSION_ID >= 50600) {
- $this->_prototype = $this->reflClass->newInstanceWithoutConstructor();
- } else {
- $this->_prototype = unserialize(sprintf('O:%d:"%s":0:{}', strlen($this->name), $this->name));
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index c676ddf..67ed6e9 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name doctrine2
-%global github_version 2.4.5
-%global github_commit c0d3cdbdfbf873871167050ab077e49b1ad02ab0
+%global github_version 2.4.6
+%global github_commit bebacf79d8d4dae9168f0f9bc6811e6c2cb6a4d9
%global composer_vendor doctrine
%global composer_project orm
@@ -145,6 +145,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 7 2014 Remi Collet <remi@fedoraproject.org> 2.4.6-1
+- Update to 2.4.6
+
* Tue Sep 23 2014 Remi Collet <remi@fedoraproject.org> 2.4.5-1
- Update to 2.4.5