summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-doctrine-orm-bin.patch22
-rw-r--r--php-doctrine-orm-version.patch2
-rw-r--r--php-doctrine-orm.spec41
4 files changed, 48 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 13f38a4..aac8c14 100644
--- a/composer.json
+++ b/composer.json
@@ -31,12 +31,12 @@
"doctrine/event-manager": "^1.1",
"doctrine/inflector": "^1.4 || ^2.0",
"doctrine/instantiator": "^1.3",
- "doctrine/lexer": "^1.0",
- "doctrine/persistence": "^2.2",
+ "doctrine/lexer": "^1.2.3",
+ "doctrine/persistence": "^2.4 || ^3",
"psr/cache": "^1 || ^2 || ^3",
"symfony/console": "^3.0 || ^4.0 || ^5.0 || ^6.0",
"symfony/polyfill-php72": "^1.23",
- "symfony/polyfill-php80": "^1.15"
+ "symfony/polyfill-php80": "^1.16"
},
"require-dev": {
"doctrine/annotations": "^1.13",
@@ -44,6 +44,7 @@
"phpbench/phpbench": "^0.16.10 || ^1.0",
"phpstan/phpstan": "~1.4.10 || 1.5.0",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
+ "psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.6.2",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
diff --git a/php-doctrine-orm-bin.patch b/php-doctrine-orm-bin.patch
index f775e0c..13d55fb 100644
--- a/php-doctrine-orm-bin.patch
+++ b/php-doctrine-orm-bin.patch
@@ -1,12 +1,14 @@
diff -up ./bin/doctrine.php.rpm1 ./bin/doctrine.php
---- ./bin/doctrine.php.rpm1 2021-10-04 09:50:51.000000000 +0200
-+++ ./bin/doctrine.php 2021-10-04 10:01:30.938203159 +0200
-@@ -1,19 +1,10 @@
+--- ./bin/doctrine.php.rpm1 2022-04-20 08:53:37.075738715 +0200
++++ ./bin/doctrine.php 2022-04-20 08:55:11.484503176 +0200
+@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
use Symfony\Component\Console\Helper\HelperSet;
- use Doctrine\ORM\Tools\Console\ConsoleRunner;
+@@ -13,17 +14,7 @@ fwrite(
+
+ echo PHP_EOL . PHP_EOL;
-$autoloadFiles = [
- __DIR__ . '/../vendor/autoload.php',
@@ -24,9 +26,9 @@ diff -up ./bin/doctrine.php.rpm1 ./bin/doctrine.php
$directories = [getcwd(), getcwd() . DIRECTORY_SEPARATOR . 'config'];
diff -up ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 ./lib/Doctrine/ORM/Tools/Setup.php
---- ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 2021-10-04 09:50:51.000000000 +0200
-+++ ./lib/Doctrine/ORM/Tools/Setup.php 2021-10-04 09:59:00.880718552 +0200
-@@ -45,7 +45,11 @@ class Setup
+--- ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 2022-04-20 08:49:16.000000000 +0200
++++ ./lib/Doctrine/ORM/Tools/Setup.php 2022-04-20 08:53:37.075738715 +0200
+@@ -52,7 +52,11 @@ class Setup
public static function registerAutoloadDirectory($directory)
{
if (! class_exists('Doctrine\Common\ClassLoader', false)) {
@@ -40,9 +42,9 @@ diff -up ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 ./lib/Doctrine/ORM/Tools/Setup.
$loader = new ClassLoader('Doctrine', $directory);
diff -up ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php
---- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 2021-10-04 09:59:00.880718552 +0200
-+++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2021-10-04 09:59:52.206542282 +0200
-@@ -52,7 +52,7 @@ class SetupTest extends OrmTestCase
+--- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 2022-04-20 08:49:16.000000000 +0200
++++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2022-04-20 08:53:37.075738715 +0200
+@@ -54,7 +54,7 @@ class SetupTest extends TestCase
public function testDirectoryAutoload(): void
{
diff --git a/php-doctrine-orm-version.patch b/php-doctrine-orm-version.patch
index 4838292..ea72431 100644
--- a/php-doctrine-orm-version.patch
+++ b/php-doctrine-orm-version.patch
@@ -9,7 +9,7 @@ diff -up ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php.rpm2 ./lib/Doctrine/
use Doctrine\DBAL\Tools\Console as DBALConsole;
use Doctrine\ORM\EntityManagerInterface;
use Doctrine\ORM\Tools\Console\EntityManagerProvider\ConnectionFromManagerProvider;
-@@ -60,7 +59,7 @@ final class ConsoleRunner
+@@ -62,7 +61,7 @@ final class ConsoleRunner
*/
public static function createApplication($helperSetOrProvider, array $commands = []): Application
{
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 1d42b2d..3f71ae6 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.11.3
-%global github_commit 4af1aa317713d5f3dbc57b22237d1acb8477079c
+%global github_version 2.12.0
+%global github_commit d5503644314ed825fe4b276a588458a033fa3e7c
%global composer_vendor doctrine
%global composer_project orm
@@ -45,12 +45,12 @@
# "doctrine/instantiator": "^1.3"
%global instantiator_min_ver 1.3
%global instantiator_max_ver 2
-# "doctrine/lexer": "^1.0"
-%global lexer_min_ver 1.0
+# "doctrine/lexer": "^1.2.3"
+%global lexer_min_ver 1.2.3
%global lexer_max_ver 2
-# "doctrine/persistence": "^2.2"
-%global persistence_min_ver 2.2
-%global persistence_max_ver 3
+# "doctrine/persistence": "^2.4 || ^3"
+%global persistence_min_ver 2.4
+%global persistence_max_ver 4
# "doctrine/event-manager": "^1.1"
%global event_min_ver 1.1
%global event_max_ver 2
@@ -62,12 +62,15 @@
%global sym_cache_min_ver 4.4
%global sym_cache_max_ver 7
# "symfony/polyfill-php72": "^1.23",
-# "symfony/polyfill-php80": "^1.15"
+# "symfony/polyfill-php80": "^1.16"
%global sym_poly_min_ver 1.23
%global sym_poly_max_ver 2
# "psr/cache": "^1 || ^2 || ^3",
%global psr_cache_min_ver 1
%global psr_cache_max_ver 4
+# "psr/log": "^1 || ^2 || ^3",
+%global psr_log_min_ver 1
+%global psr_log_max_ver 4
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -116,7 +119,8 @@ BuildRequires: (php-composer(symfony/yaml) >= %{symfony_min_ver}
BuildRequires: (php-composer(symfony/cache) >= %{sym_cache_min_ver} with php-composer(symfony/cache) < %{sym_cache_max_ver})
BuildRequires: (php-composer(symfony/polyfill-php80) >= %{sym_poly_min_ver} with php-composer(symfony/polyfill-php80) < %{sym_poly_max_ver})
BuildRequires: (php-composer(psr/cache) >= %{psr_cache_min_ver} with php-composer(psr/cache) < %{psr_cache_max_ver})
-# remirepo:32
+BuildRequires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
+# remirepo:34
%else
BuildRequires: php-doctrine-annotations >= %{annotations_min_ver}
BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
@@ -148,6 +152,8 @@ BuildRequires: php-composer(symfony/polyfill-php80) < %{sym_poly_max_ver}
BuildRequires: php-composer(symfony/polyfill-php80) >= %{sym_poly_min_ver}
BuildRequires: php-composer(psr/cache) < %{psr_cache_max_ver}
BuildRequires: php-composer(psr/cache) >= %{psr_cache_min_ver}
+BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
+BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.4
@@ -290,7 +296,10 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\ORM\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
- '%{phpdir}/Doctrine/Persistence2/autoload.php',
+ [
+ '%{phpdir}/Doctrine/Persistence3/autoload.php',
+ '%{phpdir}/Doctrine/Persistence2/autoload.php',
+ ],
'%{phpdir}/Doctrine/Common/Annotations/autoload.php',
'%{phpdir}/Doctrine/Common3/autoload.php',
[
@@ -361,6 +370,10 @@ cat > bootstrap.php <<'BOOTSTRAP'
require_once '%{buildroot}%{phpdir}/Doctrine/ORM/autoload.php';
\Fedora\Autoloader\Dependencies::required([
[
+ '%{phpdir}/Psr/Log3/autoload.php',
+ '%{phpdir}/Psr/Log2/autoload.php',
+ '%{phpdir}/Psr/Log/autoload.php',
+ ], [
'%{phpdir}/Symfony6/Component/Cache/autoload.php',
'%{phpdir}/Symfony5/Component/Cache/autoload.php',
'%{phpdir}/Symfony4/Component/Cache/autoload.php',
@@ -371,6 +384,9 @@ require_once '%{buildroot}%{phpdir}/Doctrine/ORM/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Performance\\', __DIR__.'/tests/Doctrine/Performance');
BOOTSTRAP
+# test failing only in mock
+rm tests/Doctrine/Tests/ORM/Functional/Ticket/DDC742Test.php
+
: Upstream tests
RETURN_CODE=0
for CMDARG in "php %{phpunit}" php74 php80 php81; do
@@ -400,6 +416,11 @@ exit $RETURN_CODE
%changelog
+* Wed Apr 20 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on doctrine/persistence 2.4 and allow 3
+- raise dependency on doctrine/lexer 1.2.3
+
* Wed Apr 20 2022 Remi Collet <remi@remirepo.net> - 2.11.3-1
- update to 2.11.3