summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-doctrine-orm-bin.patch44
-rw-r--r--php-doctrine-orm-version.patch21
-rw-r--r--php-doctrine-orm.spec16
4 files changed, 42 insertions, 41 deletions
diff --git a/composer.json b/composer.json
index 1e5ddef..bd40c08 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
"doctrine/annotations": "^1.11.1",
"doctrine/cache": "^1.9.1",
"doctrine/collections": "^1.5",
- "doctrine/common": "^3.0",
+ "doctrine/common": "^3.0.3",
"doctrine/dbal": "^2.10.0",
"doctrine/event-manager": "^1.1",
"doctrine/inflector": "^1.4|^2.0",
diff --git a/php-doctrine-orm-bin.patch b/php-doctrine-orm-bin.patch
index 37e0e16..93d6e84 100644
--- a/php-doctrine-orm-bin.patch
+++ b/php-doctrine-orm-bin.patch
@@ -1,7 +1,6 @@
-diff --git a/bin/doctrine.php b/bin/doctrine.php
-index 842c5493f..e1ccb7506 100755
---- a/bin/doctrine.php
-+++ b/bin/doctrine.php
+diff -up ./bin/doctrine.php.rpm ./bin/doctrine.php
+--- ./bin/doctrine.php.rpm 2021-02-24 11:42:32.000000000 +0100
++++ ./bin/doctrine.php 2021-02-24 11:43:44.654144234 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
@@ -26,27 +25,14 @@ index 842c5493f..e1ccb7506 100755
$directories = [getcwd(), getcwd() . DIRECTORY_SEPARATOR . 'config'];
-diff -up a/tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm b/tests/Doctrine/Tests/ORM/Tools/SetupTest.php
---- a/tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm 2019-09-30 08:35:50.547638239 +0200
-+++ b/tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2019-09-30 08:37:02.769360851 +0200
-@@ -43,7 +43,7 @@ class SetupTest extends OrmTestCase
-
- public function testDirectoryAutoload()
- {
-- Setup::registerAutoloadDirectory(__DIR__ . "/../../../../../vendor/doctrine/common/lib");
-+ Setup::registerAutoloadDirectory("/usr/share/php");
-
- $this->assertEquals($this->originalAutoloaderCount + 2, count(spl_autoload_functions()));
- }
-
diff -up ./lib/Doctrine/ORM/Tools/Setup.php.rpm ./lib/Doctrine/ORM/Tools/Setup.php
---- ./lib/Doctrine/ORM/Tools/Setup.php.rpm 2020-05-27 11:28:24.144920624 +0200
-+++ ./lib/Doctrine/ORM/Tools/Setup.php 2020-05-27 11:29:14.330733814 +0200
-@@ -45,7 +45,11 @@ class Setup
+--- ./lib/Doctrine/ORM/Tools/Setup.php.rpm 2021-02-24 11:43:44.654144234 +0100
++++ ./lib/Doctrine/ORM/Tools/Setup.php 2021-02-24 11:45:51.890721815 +0100
+@@ -54,7 +54,11 @@ class Setup
public static function registerAutoloadDirectory($directory)
{
- if (!class_exists('Doctrine\Common\ClassLoader', false)) {
-- require_once $directory . "/Doctrine/Common/ClassLoader.php";
+ if (! class_exists('Doctrine\Common\ClassLoader', false)) {
+- require_once $directory . '/Doctrine/Common/ClassLoader.php';
+ if (file_exists($directory . "/Doctrine/Common3/ClassLoader.php")) {
+ require_once $directory . "/Doctrine/Common3/ClassLoader.php";
+ } else {
@@ -54,4 +40,16 @@ diff -up ./lib/Doctrine/ORM/Tools/Setup.php.rpm ./lib/Doctrine/ORM/Tools/Setup.p
+ }
}
- $loader = new ClassLoader("Doctrine", $directory);
+ $loader = new ClassLoader('Doctrine', $directory);
+diff -up ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php
+--- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm 2021-02-24 11:43:44.654144234 +0100
++++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2021-02-24 11:45:10.370859668 +0100
+@@ -55,7 +55,7 @@ class SetupTest extends OrmTestCase
+
+ public function testDirectoryAutoload(): void
+ {
+- Setup::registerAutoloadDirectory(__DIR__ . '/../../../../../vendor/doctrine/common/lib');
++ Setup::registerAutoloadDirectory("/usr/share/php");
+
+ $this->assertEquals($this->originalAutoloaderCount + 2, count(spl_autoload_functions()));
+ }
diff --git a/php-doctrine-orm-version.patch b/php-doctrine-orm-version.patch
index 3329460..471edd8 100644
--- a/php-doctrine-orm-version.patch
+++ b/php-doctrine-orm-version.patch
@@ -1,17 +1,17 @@
diff -up ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php.rpm ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php
---- ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php.rpm 2020-02-17 10:57:11.784461836 +0100
-+++ ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php 2020-02-17 10:58:14.085234990 +0100
-@@ -23,7 +23,6 @@ use Doctrine\DBAL\Tools\Console as DBALC
+--- ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php.rpm 2021-02-24 11:46:38.401567397 +0100
++++ ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php 2021-02-24 11:48:56.874107710 +0100
+@@ -24,7 +24,6 @@ use Doctrine\DBAL\Tools\Console as DBALC
use Doctrine\ORM\EntityManagerInterface;
use Doctrine\ORM\Tools\Console\Helper\EntityManagerHelper;
use OutOfBoundsException;
-use PackageVersions\Versions;
use Symfony\Component\Console\Application;
+ use Symfony\Component\Console\Command\Command as SymfonyCommand;
use Symfony\Component\Console\Helper\HelperSet;
-
-@@ -75,7 +74,7 @@ final class ConsoleRunner
+@@ -68,7 +67,7 @@ final class ConsoleRunner
*/
- public static function createApplication(HelperSet $helperSet, array $commands = []) : Application
+ public static function createApplication(HelperSet $helperSet, array $commands = []): Application
{
- $cli = new Application('Doctrine Command Line Interface', Versions::getVersion('doctrine/orm'));
+ $cli = new Application('Doctrine Command Line Interface', '@VERSION@');
@@ -19,9 +19,9 @@ diff -up ./lib/Doctrine/ORM/Tools/Console/ConsoleRunner.php.rpm ./lib/Doctrine/O
$cli->setHelperSet($helperSet);
self::addCommands($cli);
diff -up ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php.rpm ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php
---- ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php.rpm 2020-02-17 11:04:44.126876478 +0100
-+++ ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php 2020-02-17 11:04:47.738864467 +0100
-@@ -4,7 +4,6 @@ namespace Doctrine\Tests\ORM\Tools\Conso
+--- ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php.rpm 2021-02-24 11:42:32.000000000 +0100
++++ ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php 2021-02-24 11:46:38.402567394 +0100
+@@ -6,7 +6,6 @@ namespace Doctrine\Tests\ORM\Tools\Conso
use Doctrine\ORM\Tools\Console\ConsoleRunner;
use Doctrine\Tests\DoctrineTestCase;
@@ -29,7 +29,7 @@ diff -up ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php.rpm ./te
use Symfony\Component\Console\Command\Command;
use Symfony\Component\Console\Helper\HelperSet;
-@@ -21,7 +20,7 @@ final class ConsoleRunnerTest extends Do
+@@ -22,7 +21,7 @@ final class ConsoleRunnerTest extends Do
$app = ConsoleRunner::createApplication($helperSet);
self::assertSame($helperSet, $app->getHelperSet());
@@ -38,4 +38,3 @@ diff -up ./tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php.rpm ./te
self::assertTrue($app->has('dbal:import'));
self::assertTrue($app->has('dbal:reserved-words'));
-
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 22be8fb..269ee07 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-orm
#
-# Copyright (c) 2013-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.8.1
-%global github_commit 242cf1a33df1b8bc5e1b86c3ebd01db07851c833
+%global github_version 2.8.2
+%global github_commit ebae57eb9637acd8252b398df3121b120688ed5c
%global composer_vendor doctrine
%global composer_project orm
@@ -30,8 +30,8 @@
# "doctrine/collections": "^1.5"
%global collections_min_ver 1.5
%global collections_max_ver 2
-# "doctrine/common": "^3.0"
-%global common_min_ver 3.0
+# "doctrine/common": "^3.0.3"
+%global common_min_ver 3.0.3
%global common_max_ver 4
# "doctrine/dbal": "^2.10"
%global dbal_min_ver 2.10
@@ -312,7 +312,7 @@ grep -r --files-with-matches 'TestInit' tests \
| xargs sed '/TestInit/d' -i
: Load annotation register file from buildroot
-sed 's#__DIR__\s*\.\s*"/\(\.\./\)*lib#"%{buildroot}%{phpdir}#' \
+sed "/registerFile/s#__DIR__.*/lib#'%{buildroot}%{phpdir}#" \
-i tests/Doctrine/Tests/OrmTestCase.php
: Create tests bootstrap
@@ -351,6 +351,10 @@ exit $RETURN_CODE
%changelog
+* Wed Feb 24 2021 Remi Collet <remi@remirepo.net> - 2.8.2-1
+- update to 2.8.2
+- raise dependency on doctrine/common 3.0.3
+
* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 2.8.1-1
- update to 2.8.1
- raise dependency on PHP 7.2