summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-doctrine-orm.spec9
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 2f633e1..abd30bf 100644
--- a/composer.json
+++ b/composer.json
@@ -39,12 +39,12 @@
"doctrine/annotations": "^1.13",
"doctrine/coding-standard": "^9.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "0.12.99",
+ "phpstan/phpstan": "1.2.0",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
"squizlabs/php_codesniffer": "3.6.1",
"symfony/cache": "^4.4 || ^5.2",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.10.0"
+ "vimeo/psalm": "4.13.1"
},
"conflict": {
"doctrine/annotations": "<1.13 || >= 2.0"
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index b17d3aa..fe06b90 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.10.2
-%global github_commit 81d472f6f96b8b571cafefe8d2fef89ed9446a62
+%global github_version 2.10.3
+%global github_commit 7b242753466508e1dd10f67c1baee95785f845c1
%global composer_vendor doctrine
%global composer_project orm
@@ -373,7 +373,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php73 php74 php80 php81; do
+for CMDARG in "php %{phpunit}" php74 php80 php81; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} \
@@ -400,6 +400,9 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.10.3-1
+- update to 2.10.3
+
* Mon Oct 25 2021 Remi Collet <remi@remirepo.net> - 2.10.2-1
- update to 2.10.2