summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json19
-rw-r--r--php-doctrine-orm-bin.patch26
-rw-r--r--php-doctrine-orm.spec77
3 files changed, 79 insertions, 43 deletions
diff --git a/composer.json b/composer.json
index 0f4e128..34cecb1 100644
--- a/composer.json
+++ b/composer.json
@@ -24,34 +24,35 @@
"composer-runtime-api": "^2",
"ext-ctype": "*",
"doctrine/cache": "^1.12.1 || ^2.1.1",
- "doctrine/collections": "^1.5",
+ "doctrine/collections": "^1.5 || ^2.0",
"doctrine/common": "^3.0.3",
"doctrine/dbal": "^2.13.1 || ^3.2",
"doctrine/deprecations": "^0.5.3 || ^1",
- "doctrine/event-manager": "^1.1",
+ "doctrine/event-manager": "^1.2 || ^2",
"doctrine/inflector": "^1.4 || ^2.0",
"doctrine/instantiator": "^1.3",
- "doctrine/lexer": "^1.2.3",
+ "doctrine/lexer": "^1.2.3 || ^2",
"doctrine/persistence": "^2.4 || ^3",
"psr/cache": "^1 || ^2 || ^3",
- "symfony/console": "^3.0 || ^4.0 || ^5.0 || ^6.0",
+ "symfony/console": "^4.2 || ^5.0 || ^6.0",
"symfony/polyfill-php72": "^1.23",
"symfony/polyfill-php80": "^1.16"
},
"require-dev": {
- "doctrine/annotations": "^1.13",
- "doctrine/coding-standard": "^9.0",
+ "doctrine/annotations": "^1.13 || ^2",
+ "doctrine/coding-standard": "^9.0.2 || ^11.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.8.2",
+ "phpstan/phpstan": "~1.4.10 || 1.9.8",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.7.1",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
+ "symfony/var-exporter": "^4.4 || ^5.4 || ^6.2",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.26.0"
+ "vimeo/psalm": "4.30.0 || 5.4.0"
},
"conflict": {
- "doctrine/annotations": "<1.13 || >= 2.0"
+ "doctrine/annotations": "<1.13 || >= 3.0"
},
"suggest": {
"ext-dom": "Provides support for XSD validation for XML mapping files",
diff --git a/php-doctrine-orm-bin.patch b/php-doctrine-orm-bin.patch
index 13d55fb..94fae70 100644
--- a/php-doctrine-orm-bin.patch
+++ b/php-doctrine-orm-bin.patch
@@ -1,6 +1,6 @@
diff -up ./bin/doctrine.php.rpm1 ./bin/doctrine.php
---- ./bin/doctrine.php.rpm1 2022-04-20 08:53:37.075738715 +0200
-+++ ./bin/doctrine.php 2022-04-20 08:55:11.484503176 +0200
+--- ./bin/doctrine.php.rpm1 2022-09-23 11:23:08.000000000 +0200
++++ ./bin/doctrine.php 2022-09-23 11:30:54.541647836 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
@@ -26,24 +26,22 @@ diff -up ./bin/doctrine.php.rpm1 ./bin/doctrine.php
$directories = [getcwd(), getcwd() . DIRECTORY_SEPARATOR . 'config'];
diff -up ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 ./lib/Doctrine/ORM/Tools/Setup.php
---- ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 2022-04-20 08:49:16.000000000 +0200
-+++ ./lib/Doctrine/ORM/Tools/Setup.php 2022-04-20 08:53:37.075738715 +0200
-@@ -52,7 +52,11 @@ class Setup
+--- ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 2022-09-23 11:30:54.542647834 +0200
++++ ./lib/Doctrine/ORM/Tools/Setup.php 2022-09-23 11:32:10.791505590 +0200
+@@ -54,7 +54,9 @@ class Setup
public static function registerAutoloadDirectory($directory)
{
if (! class_exists('Doctrine\Common\ClassLoader', false)) {
-- require_once $directory . '/Doctrine/Common/ClassLoader.php';
+- if (file_exists($directory . '/Doctrine/Common/ClassLoader.php')) {
+ if (file_exists($directory . "/Doctrine/Common3/ClassLoader.php")) {
+ require_once $directory . "/Doctrine/Common3/ClassLoader.php";
-+ } else {
-+ require_once $directory . "/Doctrine/Common/ClassLoader.php";
-+ }
- }
-
- $loader = new ClassLoader('Doctrine', $directory);
++ } elseif (file_exists($directory . '/Doctrine/Common/ClassLoader.php')) {
+ require_once $directory . '/Doctrine/Common/ClassLoader.php';
+ } elseif (file_exists(dirname($directory) . '/src/ClassLoader.php')) {
+ require_once dirname($directory) . '/src/ClassLoader.php';
diff -up ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php
---- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 2022-04-20 08:49:16.000000000 +0200
-+++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2022-04-20 08:53:37.075738715 +0200
+--- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 2022-09-23 11:23:08.000000000 +0200
++++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2022-09-23 11:30:54.542647834 +0200
@@ -54,7 +54,7 @@ class SetupTest extends TestCase
public function testDirectoryAutoload(): void
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 8f95e1e..c6fedb6 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-orm
#
-# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2023 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.13.1
-%global github_commit 35c44a56677adb3ce796138b6e4934ce93ec6811
+%global github_version 2.14.1
+%global github_commit de7eee5ed7b1b35c99b118f26f210a8281e6db8e
%global composer_vendor doctrine
%global composer_project orm
@@ -27,9 +27,9 @@
# "doctrine/cache": "^1.12.1 || ^2.1.1"
%global cache_min_ver 1.12.1
%global cache_max_ver 3
-# "doctrine/collections": "^1.5"
+# "doctrine/collections": "^1.5 || ^2.0"
%global collections_min_ver 1.5
-%global collections_max_ver 2
+%global collections_max_ver 3
# "doctrine/common": "^3.0.3"
%global common_min_ver 3.0.3
%global common_max_ver 4
@@ -45,18 +45,19 @@
# "doctrine/instantiator": "^1.3"
%global instantiator_min_ver 1.3
%global instantiator_max_ver 2
-# "doctrine/lexer": "^1.2.3"
+# "doctrine/lexer": "^1.2.3 || ^2"
%global lexer_min_ver 1.2.3
-%global lexer_max_ver 2
+%global lexer_max_ver 3
# "doctrine/persistence": "^2.4 || ^3"
%global persistence_min_ver 2.4
%global persistence_max_ver 4
-# "doctrine/event-manager": "^1.1"
-%global event_min_ver 1.1
-%global event_max_ver 2
-# "symfony/console": "^3.0 || ^4.0 || ^5.0 || ^6.0"
+# "doctrine/event-manager": "^1.2 || ^2.0"
+%global event_min_ver 1.2
+%global event_max_ver 3
+# "symfony/console": "^4.2 || ^5.0 || ^6.0"
# "symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0"
-%global symfony_min_ver 3.4
+# "symfony/var-exporter": "^4.4 || ^5.4 || ^6.2",
+%global symfony_min_ver 4.4
%global symfony_max_ver 7
# "symfony/cache": "^4.4 || ^5.4 || ^6.0",
%global sym_cache_min_ver 4.4
@@ -115,12 +116,13 @@ BuildRequires: (php-composer(doctrine/event-manager) >= %{event_min_ver}
BuildRequires: (php-composer(doctrine/lexer) >= %{lexer_min_ver} with php-composer(doctrine/lexer) < %{lexer_max_ver})
BuildRequires: (php-composer(doctrine/persistence) >= %{persistence_min_ver} with php-composer(doctrine/persistence) < %{persistence_max_ver})
BuildRequires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
+BuildRequires: (php-composer(symfony/var-exporter) >= %{symfony_min_ver} with php-composer(symfony/var-exporter) < %{symfony_max_ver})
BuildRequires: (php-composer(symfony/yaml) >= %{symfony_min_ver} with php-composer(symfony/yaml) < %{symfony_max_ver})
BuildRequires: (php-composer(symfony/cache) >= %{sym_cache_min_ver} with php-composer(symfony/cache) < %{sym_cache_max_ver})
BuildRequires: (php-composer(symfony/polyfill-php80) >= %{sym_poly_min_ver} with php-composer(symfony/polyfill-php80) < %{sym_poly_max_ver})
BuildRequires: (php-composer(psr/cache) >= %{psr_cache_min_ver} with php-composer(psr/cache) < %{psr_cache_max_ver})
BuildRequires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
-# remirepo:34
+# remirepo:36
%else
BuildRequires: php-doctrine-annotations >= %{annotations_min_ver}
BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
@@ -144,6 +146,8 @@ BuildRequires: php-composer(doctrine/persistence) < %{persistence_max_ver}
BuildRequires: php-composer(doctrine/persistence) >= %{persistence_min_ver}
BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
+BuildRequires: php-composer(symfony/var-exporter) < %{symfony_max_ver}
+BuildRequires: php-composer(symfony/var-exporter) >= %{symfony_min_ver}
BuildRequires: php-composer(symfony/yaml) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/yaml) >= %{symfony_min_ver}
BuildRequires: php-composer(symfony/cache) < %{sym_cache_max_ver}
@@ -301,6 +305,9 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::required([
[
+ '%{phpdir}/Doctrine/Common/Lexer2/autoload.php',
+ '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
+ ], [
'%{phpdir}/Doctrine/Persistence3/autoload.php',
'%{phpdir}/Doctrine/Persistence2/autoload.php',
],
@@ -309,16 +316,18 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
[
'%{phpdir}/Doctrine/Common/Cache2/autoload.php',
'%{phpdir}/Doctrine/Common/Cache/autoload.php',
+ ], [
+ '%{phpdir}/Doctrine/Common/Collections2/autoload.php',
+ '%{phpdir}/Doctrine/Common/Collections/autoload.php',
],
- '%{phpdir}/Doctrine/Common/Collections/autoload.php',
'%{phpdir}/Doctrine/Deprecations/autoload.php',
[
'%{phpdir}/Doctrine/Inflector2/autoload.php',
'%{phpdir}/Doctrine/Common/Inflector/autoload.php',
- ],
- '%{phpdir}/Doctrine/Common/EventManager/autoload.php',
- '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
- [
+ ], [
+ '%{phpdir}/Doctrine/EventManager2/autoload.php',
+ '%{phpdir}/Doctrine/Common/EventManager/autoload.php',
+ ], [
'%{phpdir}/Doctrine/DBAL3/autoload.php',
'%{phpdir}/Doctrine/DBAL/autoload.php',
],
@@ -338,11 +347,17 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::optional([
[
+ '%{phpdir}/Symfony6/Component/VarExporter/autoload.php',
+ '%{phpdir}/Symfony5/Component/VarExporter/autoload.php',
+ '%{phpdir}/Symfony4/Component/VarExporter/autoload.php',
+ '%{phpdir}/Symfony3/Component/VarExporter/autoload.php',
+ ], [
'%{phpdir}/Symfony6/Component/Yaml/autoload.php',
'%{phpdir}/Symfony5/Component/Yaml/autoload.php',
'%{phpdir}/Symfony4/Component/Yaml/autoload.php',
'%{phpdir}/Symfony3/Component/Yaml/autoload.php',
],
+
]);
AUTOLOAD
@@ -393,12 +408,12 @@ rm tests/Doctrine/Tests/ORM/Functional/Ticket/DDC742Test.php
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php74 php80 php81; do
+for CMDARG in "php %{phpunit}" php80 php81 php82; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} \
--verbose -d memory_limit="512M" \
- --filter '^((?!(testConfigureCache|testDecimal)).)*$' \
+ --filter '^((?!(testConfigureCache|testDecimal|testCacheNamespaceShouldBeGeneratedForApcu)).)*$' \
--bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
@@ -420,6 +435,28 @@ exit $RETURN_CODE
%changelog
+* Tue Jan 17 2023 Remi Collet <remi@remirepo.net> - 2.14.1-1
+- update to 2.14.1
+
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0
+- allow doctrine/collections v2
+- allow doctrine/event-manager v2
+- allow doctrine/lexer v2
+- raise dependency on symfony/console 4.2
+
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 2.13.5-1
+- update to 2.13.5
+
+* Thu Nov 24 2022 Remi Collet <remi@remirepo.net> - 2.13.4-1
+- update to 2.13.4
+
+* Fri Oct 7 2022 Remi Collet <remi@remirepo.net> - 2.13.3-1
+- update to 2.13.3
+
+* Fri Sep 23 2022 Remi Collet <remi@remirepo.net> - 2.13.2-1
+- update to 2.13.2
+
* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 2.13.1-1
- update to 2.13.1