summaryrefslogtreecommitdiffstats
path: root/php-doctrine-orm.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-10 13:30:56 +0100
committerRemi Collet <remi@remirepo.net>2017-11-10 13:30:56 +0100
commit0a0ea3a096cfdaccff353aea53387a39136a9cbf (patch)
treea67dbc50cb840a35a7575c45fd27ddd1774b3a06 /php-doctrine-orm.spec
parentd2e3d9cf197097ebc5068d2d426c4809d46af108 (diff)
Update to 2.5.12
fix FTBFS from Koschei add patch for PHP 7.2 from https://github.com/doctrine/doctrine2/pull/6821
Diffstat (limited to 'php-doctrine-orm.spec')
-rw-r--r--php-doctrine-orm.spec28
1 files changed, 14 insertions, 14 deletions
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index ada4ad0..1155934 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name doctrine2
-%global github_version 2.5.11
-%global github_commit 249b737094f1e7cba4f0a8d19acf5be6cf3ed504
+%global github_version 2.5.12
+%global github_commit 984535cadc609e9eef8c89414aa3568ee97aa79f
%global composer_vendor doctrine
%global composer_project orm
@@ -52,7 +52,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Doctrine Object-Relational-Mapper (ORM)
Group: Development/Libraries
@@ -68,6 +68,8 @@ Source1: %{name}-get-source.sh
# 2) Auto-load using Doctrine\Common\ClassLoader
Patch0: %{name}-bin.patch
+Patch1: %{name}-php72.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -168,6 +170,7 @@ Autoloader: %{phpdir}/Doctrine/ORM/autoload.php
: Patch bin script
%patch0 -p1
sed -i 's#__PHPDIR__#%{phpdir}#g' bin/doctrine.php
+%patch1 -p1
: Remove empty file
rm -f lib/Doctrine/ORM/README.markdown
@@ -236,12 +239,6 @@ BOOTSTRAP
: Skip tests known to fail
sed \
- -e 's/function testDeleteTransactionCommitShouldEvictCache/function SKIP_testDeleteTransactionCommitShouldEvictCache/' \
- -e 's/function testInsertTransactionCommitShouldPutCache/function SKIP_testInsertTransactionCommitShouldPutCache/' \
- -e 's/function testTransactionRollBackShouldClearQueue/function SKIP_testTransactionRollBackShouldClearQueue/' \
- -e 's/function testUpdateTransactionCommitShouldPutCache/function SKIP_testUpdateTransactionCommitShouldPutCache/' \
- -i tests/Doctrine/Tests/ORM/Cache/Persister/Entity/NonStrictReadWriteCachedEntityPersisterTest.php
-sed \
-e 's/function testLoadedAssociationToManyShouldTriggerEvent/function SKIP_testLoadedAssociationToManyShouldTriggerEvent/' \
-e 's/function testLoadedAssociationToOneShouldTriggerEvent/function SKIP_testLoadedAssociationToOneShouldTriggerEvent/' \
-e 's/function testLoadedEntityUsingFindShouldTriggerEvent/function SKIP_testLoadedEntityUsingFindShouldTriggerEvent/' \
@@ -266,11 +263,6 @@ RETURN_CODE=0
PHPUNIT=$(which phpunit)
for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71 php72; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- if [ $($PHP_EXEC -r 'echo PHP_VERSION_ID;') -ge 70200 ]; then
- sed 's/function testQueryCache_HitDoesNotSaveParserResult/function SKIP_testQueryCache_HitDoesNotSaveParserResult/' \
- -i tests/Doctrine/Tests/ORM/Functional/QueryCacheTest.php
- fi
-
$PHP_EXEC $PHPUNIT --verbose -d memory_limit="512M" --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
@@ -290,6 +282,14 @@ exit $RETURN_CODE
%changelog
+* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 2.5.12-2
+- fix more tests failing since 7.1
+
+* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 2.5.12-1
+- Update to 2.5.12
+- fix FTBFS from Koschei add patch for PHP 7.2 from
+ https://github.com/doctrine/doctrine2/pull/6821
+
* Wed Sep 20 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 2.5.11-1
- Updated to 2.5.11 (RHBZ #1207905)