summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-03 08:14:46 +0200
committerRemi Collet <remi@php.net>2022-05-03 08:14:46 +0200
commitc86388b2d63da95afe617b667cc278eb4f544fc7 (patch)
treefd785b3d70bca53b2c591d8b54e21f44173ce08c
parent00a5d8d4c438ce5739ca2fc316b09d00d2ac114b (diff)
update to 2.12.2
allow doctrine/deprecations 1
-rw-r--r--composer.json8
-rw-r--r--php-doctrine-orm.spec14
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index aac8c14..5b18a8f 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"doctrine/collections": "^1.5",
"doctrine/common": "^3.0.3",
"doctrine/dbal": "^2.13.1 || ^3.2",
- "doctrine/deprecations": "^0.5.3",
+ "doctrine/deprecations": "^0.5.3 || ^1",
"doctrine/event-manager": "^1.1",
"doctrine/inflector": "^1.4 || ^2.0",
"doctrine/instantiator": "^1.3",
@@ -42,13 +42,13 @@
"doctrine/annotations": "^1.13",
"doctrine/coding-standard": "^9.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.5.0",
- "phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
+ "phpstan/phpstan": "~1.4.10 || 1.6.3",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.6.2",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.22.0"
+ "vimeo/psalm": "4.23.0"
},
"conflict": {
"doctrine/annotations": "<1.13 || >= 2.0"
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index f3d2a6b..f283039 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.12.1
-%global github_commit 2e4a8722721b934149ff53b191522a6829b6d73b
+%global github_version 2.12.2
+%global github_commit 8291a7f09b12d14783ed6537b4586583d155869e
%global composer_vendor doctrine
%global composer_project orm
@@ -36,9 +36,9 @@
# "doctrine/dbal": "^2.13.1 || ^3.2"
%global dbal_min_ver 2.13.1
%global dbal_max_ver 4
-# "doctrine/deprecations": "^0.5.3"
+# "doctrine/deprecations": "^0.5.3 || ^1"
%global deprecations_min_ver 0.5.3
-%global deprecations_max_ver 1
+%global deprecations_max_ver 2
# "doctrine/inflector": "^1.4 || ^2.0"
%global inflector_min_ver 1.4
%global inflector_max_ver 3
@@ -156,7 +156,7 @@ BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.4
+BuildRequires: phpunit9 >= 9.5
BuildRequires: php-pdo
# phpcompatinfo (computed from version 2.5.11)
BuildRequires: php-ctype
@@ -416,6 +416,10 @@ exit $RETURN_CODE
%changelog
+* Tue May 3 2022 Remi Collet <remi@remirepo.net> - 2.12.2-1
+- update to 2.12.2
+- allow doctrine/deprecations 1
+
* Mon Apr 25 2022 Remi Collet <remi@remirepo.net> - 2.12.1-1
- update to 2.12.1