summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-08 16:12:31 +0200
committerRemi Collet <remi@php.net>2022-08-08 16:12:31 +0200
commitb2caf46a9cce27d294cef74acf6d7fabe7c76fcf (patch)
treea0f96b93428a6a3dc43bd3d82c6f51991d78f93d
parent70ef3a620f7c26d6924bd247f29af53c87505f24 (diff)
update to 2.13.1
-rw-r--r--composer.json7
-rw-r--r--php-doctrine-orm.spec13
2 files changed, 14 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index a2f2531..0f4e128 100644
--- a/composer.json
+++ b/composer.json
@@ -42,18 +42,19 @@
"doctrine/annotations": "^1.13",
"doctrine/coding-standard": "^9.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.7.13",
+ "phpstan/phpstan": "~1.4.10 || 1.8.2",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"psr/log": "^1 || ^2 || ^3",
- "squizlabs/php_codesniffer": "3.7.0",
+ "squizlabs/php_codesniffer": "3.7.1",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.23.0"
+ "vimeo/psalm": "4.26.0"
},
"conflict": {
"doctrine/annotations": "<1.13 || >= 2.0"
},
"suggest": {
+ "ext-dom": "Provides support for XSD validation for XML mapping files",
"symfony/cache": "Provides cache support for Setup Tool with doctrine/cache 2.0",
"symfony/yaml": "If you want to use YAML Metadata Mapping Driver"
},
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 5a595b7..9c043b4 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.12.3
-%global github_commit c05e1709e9ffb9abe8d37260a78975cc816ee385
+%global github_version 2.13.1
+%global github_commit 35c44a56677adb3ce796138b6e4934ce93ec6811
%global composer_vendor doctrine
%global composer_project orm
@@ -279,10 +279,14 @@ sed -e 's/@VERSION@/%{version}/' -i \
tests/Doctrine/Tests/ORM/Tools/Console/ConsoleRunnerTest.php
find lib -name \*.rpm\? -delete
+: move schema in librari
+cp doctrine-mapping.xsd lib/Doctrine/ORM/Mapping/Driver/
+sed -e '/doctrine-mapping.xsd/s:/../../../../..::' \
+ -i lib/Doctrine/ORM/Mapping/Driver/XmlDriver.php
+
: Remove empty file
rm -f lib/Doctrine/ORM/README.markdown
-
%build
: Create autoloader
cat <<'AUTOLOAD' | tee lib/Doctrine/ORM/autoload.php
@@ -416,6 +420,9 @@ exit $RETURN_CODE
%changelog
+* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 2.13.1-1
+- update to 2.13.1
+
* Fri Jun 17 2022 Remi Collet <remi@remirepo.net> - 2.12.3-1
- update to 2.12.3