summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 10:28:24 +0100
committerRemi Collet <remi@php.net>2022-12-20 10:28:24 +0100
commit483681f9d03737c6aab6dfcdd8b500ec80b99812 (patch)
treeaf10156f563990f8e81ce437d4ce73e674320cf5
parenta2755f796cc36dfda398860a678f67a93ff828b4 (diff)
update to 2.13.5
-rw-r--r--composer.json6
-rw-r--r--php-doctrine-orm.spec11
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index e6525f3..110b47f 100644
--- a/composer.json
+++ b/composer.json
@@ -40,15 +40,15 @@
},
"require-dev": {
"doctrine/annotations": "^1.13",
- "doctrine/coding-standard": "^9.0.2 || ^10.0",
+ "doctrine/coding-standard": "^9.0.2 || ^11.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.9.2",
+ "phpstan/phpstan": "~1.4.10 || 1.9.4",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.7.1",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.30.0"
+ "vimeo/psalm": "4.30.0 || 5.3.0"
},
"conflict": {
"doctrine/annotations": "<1.13 || >= 2.0"
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 63665d1..bbcb6ea 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.13.4
-%global github_commit a5a6cc6630ce497290396d5f206887227820a634
+%global github_version 2.13.5
+%global github_commit 099e51d8990c586778c564a9ed1eaa6401f2bc83
%global composer_vendor doctrine
%global composer_project orm
@@ -300,6 +300,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\ORM\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
[
'%{phpdir}/Doctrine/Persistence3/autoload.php',
'%{phpdir}/Doctrine/Persistence2/autoload.php',
@@ -317,7 +318,6 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Doctrine/Common/Inflector/autoload.php',
],
'%{phpdir}/Doctrine/Common/EventManager/autoload.php',
- '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
[
'%{phpdir}/Doctrine/DBAL3/autoload.php',
'%{phpdir}/Doctrine/DBAL/autoload.php',
@@ -398,7 +398,7 @@ for CMDARG in "php %{phpunit}" php80 php81 php82; do
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} \
--verbose -d memory_limit="512M" \
- --filter '^((?!(testConfigureCache|testDecimal)).)*$' \
+ --filter '^((?!(testConfigureCache|testDecimal|testCacheNamespaceShouldBeGeneratedForApcu)).)*$' \
--bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
@@ -420,6 +420,9 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 2.13.5-1
+- update to 2.13.5
+
* Thu Nov 24 2022 Remi Collet <remi@remirepo.net> - 2.13.4-1
- update to 2.13.4