summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-23 11:36:50 +0200
committerRemi Collet <remi@php.net>2022-09-23 11:36:50 +0200
commit0a4fdf15517b112bd3cfa4d264a2e0ce1248b942 (patch)
tree0834087d0e6cd42d83340c663a789db26cf22b10
parent57e138533948eab5fd67f08b3ef50d3632fc6a46 (diff)
update to 2.13.2
-rw-r--r--composer.json6
-rw-r--r--php-doctrine-orm-bin.patch26
-rw-r--r--php-doctrine-orm.spec9
3 files changed, 21 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 0f4e128..cf7b249 100644
--- a/composer.json
+++ b/composer.json
@@ -40,15 +40,15 @@
},
"require-dev": {
"doctrine/annotations": "^1.13",
- "doctrine/coding-standard": "^9.0",
+ "doctrine/coding-standard": "^9.0.2 || ^10.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.8.2",
+ "phpstan/phpstan": "~1.4.10 || 1.8.5",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.7.1",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.26.0"
+ "vimeo/psalm": "4.27.0"
},
"conflict": {
"doctrine/annotations": "<1.13 || >= 2.0"
diff --git a/php-doctrine-orm-bin.patch b/php-doctrine-orm-bin.patch
index 13d55fb..94fae70 100644
--- a/php-doctrine-orm-bin.patch
+++ b/php-doctrine-orm-bin.patch
@@ -1,6 +1,6 @@
diff -up ./bin/doctrine.php.rpm1 ./bin/doctrine.php
---- ./bin/doctrine.php.rpm1 2022-04-20 08:53:37.075738715 +0200
-+++ ./bin/doctrine.php 2022-04-20 08:55:11.484503176 +0200
+--- ./bin/doctrine.php.rpm1 2022-09-23 11:23:08.000000000 +0200
++++ ./bin/doctrine.php 2022-09-23 11:30:54.541647836 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
@@ -26,24 +26,22 @@ diff -up ./bin/doctrine.php.rpm1 ./bin/doctrine.php
$directories = [getcwd(), getcwd() . DIRECTORY_SEPARATOR . 'config'];
diff -up ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 ./lib/Doctrine/ORM/Tools/Setup.php
---- ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 2022-04-20 08:49:16.000000000 +0200
-+++ ./lib/Doctrine/ORM/Tools/Setup.php 2022-04-20 08:53:37.075738715 +0200
-@@ -52,7 +52,11 @@ class Setup
+--- ./lib/Doctrine/ORM/Tools/Setup.php.rpm1 2022-09-23 11:30:54.542647834 +0200
++++ ./lib/Doctrine/ORM/Tools/Setup.php 2022-09-23 11:32:10.791505590 +0200
+@@ -54,7 +54,9 @@ class Setup
public static function registerAutoloadDirectory($directory)
{
if (! class_exists('Doctrine\Common\ClassLoader', false)) {
-- require_once $directory . '/Doctrine/Common/ClassLoader.php';
+- if (file_exists($directory . '/Doctrine/Common/ClassLoader.php')) {
+ if (file_exists($directory . "/Doctrine/Common3/ClassLoader.php")) {
+ require_once $directory . "/Doctrine/Common3/ClassLoader.php";
-+ } else {
-+ require_once $directory . "/Doctrine/Common/ClassLoader.php";
-+ }
- }
-
- $loader = new ClassLoader('Doctrine', $directory);
++ } elseif (file_exists($directory . '/Doctrine/Common/ClassLoader.php')) {
+ require_once $directory . '/Doctrine/Common/ClassLoader.php';
+ } elseif (file_exists(dirname($directory) . '/src/ClassLoader.php')) {
+ require_once dirname($directory) . '/src/ClassLoader.php';
diff -up ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php
---- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 2022-04-20 08:49:16.000000000 +0200
-+++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2022-04-20 08:53:37.075738715 +0200
+--- ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php.rpm1 2022-09-23 11:23:08.000000000 +0200
++++ ./tests/Doctrine/Tests/ORM/Tools/SetupTest.php 2022-09-23 11:30:54.542647834 +0200
@@ -54,7 +54,7 @@ class SetupTest extends TestCase
public function testDirectoryAutoload(): void
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 8f95e1e..1c704b7 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.13.1
-%global github_commit 35c44a56677adb3ce796138b6e4934ce93ec6811
+%global github_version 2.13.2
+%global github_commit a8b02fd70fa777ca8278b9604fdef75c15c6a12f
%global composer_vendor doctrine
%global composer_project orm
@@ -393,7 +393,7 @@ rm tests/Doctrine/Tests/ORM/Functional/Ticket/DDC742Test.php
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php74 php80 php81; do
+for CMDARG in "php %{phpunit}" php74 php80 php81 php82; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} \
@@ -420,6 +420,9 @@ exit $RETURN_CODE
%changelog
+* Fri Sep 23 2022 Remi Collet <remi@remirepo.net> - 2.13.2-1
+- update to 2.13.2
+
* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 2.13.1-1
- update to 2.13.1