summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-doctrine-migrations-rpm.patch16
-rw-r--r--php-doctrine-migrations.spec12
3 files changed, 16 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index bae11be..e62f80f 100644
--- a/composer.json
+++ b/composer.json
@@ -12,8 +12,8 @@
],
"require": {
"php": "^7.1",
+ "composer/package-versions-deprecated": "^1.8",
"doctrine/dbal": "^2.9",
- "ocramius/package-versions": "^1.3",
"ocramius/proxy-manager": "^2.0.2",
"symfony/console": "^3.4||^4.0||^5.0",
"symfony/stopwatch": "^3.4||^4.0||^5.0"
diff --git a/php-doctrine-migrations-rpm.patch b/php-doctrine-migrations-rpm.patch
index 69be9f8..76288a4 100644
--- a/php-doctrine-migrations-rpm.patch
+++ b/php-doctrine-migrations-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php.rpm ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php
---- ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php.rpm 2019-03-27 09:58:41.000000000 +0100
-+++ ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php 2019-03-27 10:19:22.365477263 +0100
+--- ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php.rpm 2020-11-05 10:56:59.000000000 +0100
++++ ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php 2020-11-05 10:59:12.867450852 +0100
@@ -15,7 +15,6 @@ use Doctrine\Migrations\Tools\Console\Co
use Doctrine\Migrations\Tools\Console\Command\StatusCommand;
use Doctrine\Migrations\Tools\Console\Command\UpToDateCommand;
@@ -14,14 +14,14 @@ diff -up ./lib/Doctrine/Migrations/Tools/Console/ConsoleRunner.php.rpm ./lib/Doc
public static function createApplication(HelperSet $helperSet, array $commands = []) : Application
{
- $cli = new Application('Doctrine Migrations', Versions::getVersion('doctrine/migrations'));
-+ $cli = new Application('Doctrine Migrations', '2.0.0');
++ $cli = new Application('Doctrine Migrations', '@VERSION@');
$cli->setCatchExceptions(true);
$cli->setHelperSet($helperSet);
self::addCommands($cli);
diff -up ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php.rpm ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php
---- ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php.rpm 2019-03-27 10:20:22.799818585 +0100
-+++ ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php 2019-03-27 10:20:48.070961326 +0100
-@@ -17,7 +17,6 @@ use Doctrine\Migrations\Tools\Console\Co
+--- ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php.rpm 2020-11-05 10:56:59.000000000 +0100
++++ ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php 2020-11-05 11:00:29.151171587 +0100
+@@ -18,7 +18,6 @@ use Doctrine\Migrations\Tools\Console\Co
use Doctrine\ORM\EntityManager;
use Doctrine\ORM\Tools\Console\Helper\EntityManagerHelper;
use Doctrine\ORM\Tools\Setup as OrmSetup;
@@ -29,8 +29,8 @@ diff -up ./tests/Doctrine/Migrations/Tests/Functional/CliTest.php.rpm ./tests/Do
use ReflectionClass;
use RuntimeException;
use Symfony\Component\Console\Application;
-@@ -227,7 +226,7 @@ class CliTest extends MigrationTestCase
- );
+@@ -281,7 +280,7 @@ class CliTest extends MigrationTestCase
+ $this->deleteMigrationFiles();
$this->conn = $this->getSqliteConnection();
- $this->application = new Application('Doctrine Migrations Test', Versions::getVersion('doctrine/migrations'));
diff --git a/php-doctrine-migrations.spec b/php-doctrine-migrations.spec
index 7d845e1..ce2727f 100644
--- a/php-doctrine-migrations.spec
+++ b/php-doctrine-migrations.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit a3987131febeb0e9acb3c47ab0df0af004588934
+%global gh_commit 100e85a8509b521f010901890f042e9401a3043b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project migrations
@@ -25,7 +25,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 2.2.1
+Version: 2.3.0
Release: 1%{?dist}
Summary: PHP Doctrine Migrations project
@@ -98,8 +98,8 @@ BuildRequires: phpunit7
# From composer.json
# "require": {
# "php": "^7.1",
+# "composer/package-versions-deprecated": "^1.8",
# "doctrine/dbal": "^2.9",
-# "ocramius/package-versions": "^1.3",
# "ocramius/proxy-manager": "^2.0.2",
# "symfony/console": "^3.4||^4.0||^5.0",
# "symfony/stopwatch": "^3.4||^4.0||^5.0"
@@ -229,12 +229,11 @@ chmod -w tests/Doctrine/Migrations/Tests/Functional/_files
# testMigrationLifecycleFromCommandLine fails with some symfony versions (4.2) ok with newer (4.3)
: Run test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
TMP=$(mktemp -d)
if which $cmd; then
TMPDIR=$TMP $cmd %{_bindir}/phpunit7 \
--bootstrap vendor/autoload.php \
- --filter '^((?!(testMigrationLifecycleFromCommandLine)).)*$' \
--verbose || ret=1
rm -rf $TMP
fi
@@ -259,6 +258,9 @@ exit $ret
%changelog
+* Thu Nov 5 2020 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+
* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 2.2.1-1
- update to 2.2.1