summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-13 14:10:36 +0100
committerRemi Collet <remi@remirepo.net>2019-11-13 14:10:36 +0100
commite83cb88018a55ccfc737e0bce95ce71518b9a6c9 (patch)
treee243e52b3a66eb6c4c0e27b2b7cab7062bfd8a3d
parent4d80a05a831d58c07010c555d924a48be7123d63 (diff)
- update to 2.2.0
- allow Symfony 5 (not yet available)
-rw-r--r--composer.json12
-rw-r--r--php-doctrine-migrations.spec43
2 files changed, 31 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index c7de738..bae11be 100644
--- a/composer.json
+++ b/composer.json
@@ -15,22 +15,22 @@
"doctrine/dbal": "^2.9",
"ocramius/package-versions": "^1.3",
"ocramius/proxy-manager": "^2.0.2",
- "symfony/console": "^3.4||^4.0",
- "symfony/stopwatch": "^3.4||^4.0"
+ "symfony/console": "^3.4||^4.0||^5.0",
+ "symfony/stopwatch": "^3.4||^4.0||^5.0"
},
"require-dev": {
"ext-pdo_sqlite": "*",
"doctrine/coding-standard": "^6.0",
"doctrine/orm": "^2.6",
"jdorn/sql-formatter": "^1.1",
- "mikey179/vfsStream": "^1.6",
+ "mikey179/vfsstream": "^1.6",
"phpstan/phpstan": "^0.10",
"phpstan/phpstan-deprecation-rules": "^0.10",
"phpstan/phpstan-phpunit": "^0.10",
"phpstan/phpstan-strict-rules": "^0.10",
"phpunit/phpunit": "^7.0",
- "symfony/process": "^3.4||^4.0",
- "symfony/yaml": "^3.4||^4.0"
+ "symfony/process": "^3.4||^4.0||^5.0",
+ "symfony/yaml": "^3.4||^4.0||^5.0"
},
"suggest": {
"jdorn/sql-formatter": "Allows to generate formatted SQL with the diff command.",
@@ -51,7 +51,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.1.x-dev"
+ "dev-master": "2.2.x-dev"
}
},
"bin": [
diff --git a/php-doctrine-migrations.spec b/php-doctrine-migrations.spec
index 1e3465f..d1b4411 100644
--- a/php-doctrine-migrations.spec
+++ b/php-doctrine-migrations.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit a89fa87a192e90179163c1e863a145c13337f442
+%global gh_commit 8e124252d2f6be1124017d746d5994dd4095d66f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project migrations
@@ -25,7 +25,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 2.1.1
+Version: 2.2.0
Release: 1%{?dist}
Summary: PHP Doctrine Migrations project
@@ -53,8 +53,8 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/dbal) >= 2.9 with php-composer(doctrine/dbal) < 3)
-BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 5)
-BuildRequires: (php-composer(symfony/stopwatch) >= 3.4 with php-composer(symfony/stopwatch) < 5)
+BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
+BuildRequires: (php-composer(symfony/stopwatch) >= 3.4 with php-composer(symfony/stopwatch) < 6)
BuildRequires: (php-composer(ocramius/proxy-manager) >= 2.0.2 with php-composer(ocramius/proxy-manager) < 3)
# From composer.json
# "require-dev": {
@@ -62,20 +62,20 @@ BuildRequires: (php-composer(ocramius/proxy-manager) >= 2.0.2 with php-composer(
# "doctrine/coding-standard": "^6.0",
# "doctrine/orm": "^2.6",
# "jdorn/sql-formatter": "^1.1",
-# "mikey179/vfsStream": "^1.6",
+# "mikey179/vfsstream": "^1.6",
# "phpstan/phpstan": "^0.10",
# "phpstan/phpstan-deprecation-rules": "^0.10",
# "phpstan/phpstan-phpunit": "^0.10",
# "phpstan/phpstan-strict-rules": "^0.10",
# "phpunit/phpunit": "^7.0",
-# "symfony/process": "^3.4||^4.0",
-# "symfony/yaml": "^3.4||^4.0"
+# "symfony/process": "^3.4||^4.0||^5.0",
+# "symfony/yaml": "^3.4||^4.0||^5.0"
BuildRequires: php-pdo_sqlite
BuildRequires: (php-composer(doctrine/orm) >= 2.6 with php-composer(doctrine/orm) < 3)
-BuildRequires: (php-composer(symfony/process) >= 3.4 with php-composer(symfony/process) < 5)
-BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 5)
+BuildRequires: (php-composer(symfony/process) >= 3.4 with php-composer(symfony/process) < 6)
+BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
BuildRequires: (php-composer(jdorn/sql-formatter) >= 1.1 with php-composer(jdorn/sql-formatter) < 2)
-BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6 with php-composer(mikey179/vfsstream) < 2)
# remirepo:15
%else
BuildRequires: php-composer(doctrine/dbal) < 3
@@ -89,7 +89,7 @@ BuildRequires: php-composer(doctrine/orm) >= 2.5
BuildRequires: php-symfony3-yaml >= 3.3
BuildRequires: php-composer(jdorn/sql-formatter) < 2
BuildRequires: php-composer(jdorn/sql-formatter) >= 1.1
-BuildRequires: php-composer(mikey179/vfsStream) < 2
+BuildRequires: php-composer(mikey179/vfsstream) < 2
BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
%endif
BuildRequires: phpunit7
@@ -101,8 +101,8 @@ BuildRequires: phpunit7
# "doctrine/dbal": "^2.9",
# "ocramius/package-versions": "^1.3",
# "ocramius/proxy-manager": "^2.0.2",
-# "symfony/console": "^3.4||^4.0",
-# "symfony/stopwatch": "^3.4||^4.0"
+# "symfony/console": "^3.4||^4.0||^5.0",
+# "symfony/stopwatch": "^3.4||^4.0||^5.0"
# "suggest": {
# "jdorn/sql-formatter": "Allows to generate formatted SQL with the diff command.",
# "symfony/yaml": "Allows the use of yaml for migration configuration files."
@@ -111,11 +111,11 @@ Requires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/dbal) >= 2.9 with php-composer(doctrine/dbal) < 3)
-Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 5)
-Requires: (php-composer(symfony/stopwatch) >= 3.4 with php-composer(symfony/stopwatch) < 5)
+Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
+Requires: (php-composer(symfony/stopwatch) >= 3.4 with php-composer(symfony/stopwatch) < 6)
Requires: (php-composer(ocramius/proxy-manager) >= 2.0.2 with php-composer(ocramius/proxy-manager) < 3)
Recommends: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
-Recommends: (php-composer(symfony/yaml) >= 3.3 with php-composer(symfony/yaml) < 5)
+Recommends: (php-composer(symfony/yaml) >= 3.3 with php-composer(symfony/yaml) < 6)
# remirepo:8
%else
Requires: php-composer(doctrine/dbal) < 3
@@ -174,10 +174,12 @@ cat << 'EOF' | tee -a lib/%{ns_vendor}/%{ns_project}/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{_datadir}/php/%{ns_vendor}/DBAL/autoload.php',
[
+ '%{_datadir}/php/Symfony5/Component/Console/autoload.php',
'%{_datadir}/php/Symfony4/Component/Console/autoload.php',
'%{_datadir}/php/Symfony3/Component/Console/autoload.php',
],
[
+ '%{_datadir}/php/Symfony5/Component/Stopwatch/autoload.php',
'%{_datadir}/php/Symfony4/Component/Stopwatch/autoload.php',
'%{_datadir}/php/Symfony3/Component/Stopwatch/autoload.php',
],
@@ -186,10 +188,12 @@ cat << 'EOF' | tee -a lib/%{ns_vendor}/%{ns_project}/autoload.php
\Fedora\Autoloader\Dependencies::optional([
'%{_datadir}/php/jdorn-sql-formatter/autoload.php',
[
+ '%{_datadir}/php/Symfony5/Component/Process/autoload.php',
'%{_datadir}/php/Symfony4/Component/Process/autoload.php',
'%{_datadir}/php/Symfony3/Component/Process/autoload.php',
],
[
+ '%{_datadir}/php/Symfony5/Component/Yaml/autoload.php',
'%{_datadir}/php/Symfony4/Component/Yaml/autoload.php',
'%{_datadir}/php/Symfony3/Component/Yaml/autoload.php',
],
@@ -224,8 +228,7 @@ chmod -w tests/Doctrine/Migrations/Tests/Functional/_files
: Run test suite
ret=0
-# TODO php74: Trying to access array offset on value of type int in symfony/console
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
TMP=$(mktemp -d)
if which $cmd; then
TMPDIR=$TMP $cmd %{_bindir}/phpunit7 \
@@ -254,6 +257,10 @@ exit $ret
%changelog
+* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- allow Symfony 5 (not yet available)
+
* Thu Aug 1 2019 Remi Collet <remi@remirepo.net> - 2.1.1-1
- update to 2.1.1