summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-13 14:50:05 +0100
committerRemi Collet <remi@php.net>2022-12-13 14:50:05 +0100
commit6bec1b42ad6f06d81743313c89e02b6e986651eb (patch)
treeb0fdc0c8eeea4545a874e1deee0251a09858c84a
dup v1
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json41
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-doctrine-lexer2.spec182
5 files changed, 264 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..c435647
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,41 @@
+{
+ "name": "doctrine/lexer",
+ "type": "library",
+ "description": "PHP Doctrine Lexer parser library that can be used in Top-Down, Recursive Descent Parsers.",
+ "keywords": [
+ "php",
+ "parser",
+ "lexer",
+ "annotations",
+ "docblock"
+ ],
+ "homepage": "https://www.doctrine-project.org/projects/lexer.html",
+ "license": "MIT",
+ "authors": [
+ {"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
+ {"name": "Roman Borschel", "email": "roman@code-factory.org"},
+ {"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
+ ],
+ "require": {
+ "php": "^7.1 || ^8.0"
+ },
+ "require-dev": {
+ "doctrine/coding-standard": "^9.0",
+ "phpstan/phpstan": "^1.3",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+ "vimeo/psalm": "^4.11"
+ },
+ "autoload": {
+ "psr-4": { "Doctrine\\Common\\Lexer\\": "lib/Doctrine/Common/Lexer" }
+ },
+ "autoload-dev": {
+ "psr-4": { "Doctrine\\Tests\\": "tests/Doctrine" }
+ },
+ "config": {
+ "allow-plugins": {
+ "composer/package-versions-deprecated": true,
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "sort-packages": true
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..97be9f6
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global github_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global github_name/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^%global github_version/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global github_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-doctrine-lexer2.spec b/php-doctrine-lexer2.spec
new file mode 100644
index 0000000..282bf17
--- /dev/null
+++ b/php-doctrine-lexer2.spec
@@ -0,0 +1,182 @@
+# remirepo spec file for php-doctrine-lexer, from:
+#
+# Fedora spec file for php-doctrine-lexer
+#
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+# Github
+%global github_owner doctrine
+%global github_name lexer
+%global github_version 1.2.3
+%global github_commit c268e882d4dbdd85e36e4ad69e02dc284f89d229
+%global github_short %(c=%{github_commit}; echo ${c:0:7})
+# Namespace
+%global ns_vendor Doctrine
+%global ns_project Common
+%global ns_subproj Lexer
+# Packagist
+%global composer_vendor doctrine
+%global composer_project lexer
+
+# "php": "^7.1 || ^8.0"
+%global php_min_ver 7.1
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: Base library for a lexer that can be used in top-down, recursive descent parsers
+
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+# git snapshot with tests
+Source0: %{name}-%{github_version}-%{github_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: phpunit9
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo (computed from version 1.1.0)
+Requires: php-pcre
+Requires: php-reflection
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+Base library for a lexer that can be used in top-down, recursive descent
+parsers.
+
+This lexer is used in Doctrine Annotations and in Doctrine ORM (DQL).
+
+Autoloader: %{phpdir}/%{ns_vendor}/%{ns_project}/%{ns_subproj}/autoload.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Generate a simple autoloader
+%{_bindir}/phpab \
+ --output lib/%{ns_vendor}/%{ns_project}/%{ns_subproj}/autoload.php \
+ --template fedora \
+ lib/%{ns_vendor}/%{ns_project}
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}
+cp -rp lib/* %{buildroot}%{phpdir}/
+
+
+%check
+%if %{with_tests}
+: Generate autoloader
+mkdir vendor
+%{_bindir}/phpab \
+ --output vendor/autoload.php \
+ --template fedora \
+ tests
+
+cat << 'EOF' | tee -a vendor/autoload.php
+require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/%{ns_subproj}/autoload.php";
+EOF
+
+# we don't want PHPStan (which pull nette framework)
+
+: Run test suite
+ret=0
+for cmd in php php74 php80 php81; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 \
+ --bootstrap vendor/autoload.php \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{_datadir}/php/Doctrine
+%dir %{_datadir}/php/Doctrine/Common
+ %{_datadir}/php/Doctrine/Common/Lexer
+
+
+%changelog
+* Mon Feb 28 2022 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+
+* Wed Jan 12 2022 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+- switch to phpunit9
+
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1 (no change)
+
+* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
+* Thu Aug 1 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- raise dependency on PHP 7.2
+- sources from git snapshot
+- run upstream test suite during build
+- use classmap autoloader
+
+* Tue Jun 11 2019 Remi Collet <remi@remirepo.net> - 1.0.2-1
+- update to 1.0.2
+
+* Sat May 13 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.1-8
+- Switch autoloader to php-composer(fedora/autoloader)
+
+* Sat Jun 27 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.1-5
+- Updated autoloader with trailing separator
+
+* Wed Jun 24 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.1-4
+- Added autoloader dependency
+
+* Tue Jun 23 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.1-3
+- Added autoloader
+
+* Mon Jan 05 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.1-1
+- Updated to 1.0.1 (same commit but tagged version instead of snapshot; BZ #1178808)
+- %%license usage
+
+* Sun Dec 07 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0-5.20140909git83893c5
+- Updated to latest snapshot (required for php-egulias-email-validator 1.2.6)
+
+* Fri Jun 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0-4.20131220gitf12a5f7
+- Added php-composer(%%{composer_vendor}/%%{composer_project}) virtual provide
+
+* Sat Jan 11 2014 Remi Collet <rpms@famillecollet.com> 1.0-2.20131220gitf12a5f7
+- backport for remi repo
+
+* Mon Jan 06 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-2.20131220gitf12a5f7
+- Conditional %%{?dist}
+
+* Mon Dec 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-1.20131220gitf12a5f7
+- Initial package