summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-doctrine-lexer.spec11
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 0d8e5ad..3432bae 100644
--- a/composer.json
+++ b/composer.json
@@ -17,7 +17,7 @@
{"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
],
"require": {
- "php": "^7.2"
+ "php": "^7.2 || ^8.0"
},
"require-dev": {
"doctrine/coding-standard": "^6.0",
diff --git a/php-doctrine-lexer.spec b/php-doctrine-lexer.spec
index 8b6a78f..748c4e5 100644
--- a/php-doctrine-lexer.spec
+++ b/php-doctrine-lexer.spec
@@ -12,8 +12,8 @@
# Github
%global github_owner doctrine
%global github_name lexer
-%global github_version 1.2.0
-%global github_commit 5242d66dbeb21a30dd8a3e66bf7a73b66e05e1f6
+%global github_version 1.2.1
+%global github_commit e864bbf5904cb8f5bb334f99209b48018522f042
%global github_short %(c=%{github_commit}; echo ${c:0:7})
# Namespace
%global ns_vendor Doctrine
@@ -23,7 +23,7 @@
%global composer_vendor doctrine
%global composer_project lexer
-# "php": ">=7.2"
+# "php": "^7.2 || ^8.0"
%global php_min_ver 7.2
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -103,7 +103,7 @@ EOF
: Run test suite
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 \
--bootstrap vendor/autoload.php \
@@ -127,6 +127,9 @@ exit $ret
%changelog
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1 (no change)
+
* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0