summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-11 15:32:21 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-11 15:32:21 +0100
commit04573e54ee55bd11f4e814919b08ce0d09acf3e8 (patch)
treeceb01cedf6ed108ebea1f2b87a3df9a91f64df34
php-doctrine-lexer: import from rawhide
-rw-r--r--php-doctrine-lexer.spec64
1 files changed, 64 insertions, 0 deletions
diff --git a/php-doctrine-lexer.spec b/php-doctrine-lexer.spec
new file mode 100644
index 0000000..6cf88e5
--- /dev/null
+++ b/php-doctrine-lexer.spec
@@ -0,0 +1,64 @@
+%global github_owner doctrine
+%global github_name lexer
+%global github_version 1.0
+%global github_commit f12a5f74e5f4a9e3f558f3288504e121edfad891
+# Additional commits after v1.0 tag
+%global github_release .20131220git%(c=%{github_commit}; echo ${c:0:7})
+
+# "php": ">=5.3.2"
+%global php_min_ver 5.3.2
+
+Name: php-%{github_owner}-%{github_name}
+Version: %{github_version}
+Release: 2%{?github_release}%{?dist}
+Summary: Base library for a lexer that can be used in top-down, recursive descent parsers
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo (computed from v1.0 git commit f12a5f74e5f4a9e3f558f3288504e121edfad891)
+Requires: php-pcre
+Requires: php-reflection
+
+%description
+Base library for a lexer that can be used in top-down, recursive descent
+parsers.
+
+This lexer is used in Doctrine Annotations and in Doctrine ORM (DQL).
+
+
+%prep
+%setup -q -n %{github_name}-%{github_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -p %{buildroot}/%{_datadir}/php
+cp -rp lib/* %{buildroot}/%{_datadir}/php/
+
+
+%check
+# No upstream tests
+
+
+%files
+%doc LICENSE *.md composer.json
+%dir %{_datadir}/php/Doctrine
+%dir %{_datadir}/php/Doctrine/Common
+ %{_datadir}/php/Doctrine/Common/Lexer
+
+
+%changelog
+* Mon Jan 06 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-2.20131220gitf12a5f7
+- Conditional %%{?dist}
+
+* Mon Dec 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-1.20131220gitf12a5f7
+- Initial package