summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--composer.json4
-rw-r--r--php-doctrine-instantiator.spec11
3 files changed, 11 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 4fba95c..fab8172 100644
--- a/composer.json
+++ b/composer.json
@@ -21,12 +21,12 @@
"require-dev": {
"ext-phar": "*",
"ext-pdo": "*",
- "doctrine/coding-standard": "^9",
+ "doctrine/coding-standard": "^9 || ^11",
"phpbench/phpbench": "^0.16 || ^1",
"phpstan/phpstan": "^1.4",
"phpstan/phpstan-phpunit": "^1",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
- "vimeo/psalm": "^4.22"
+ "vimeo/psalm": "^4.30 || ^5.4"
},
"autoload": {
"psr-4": {
diff --git a/php-doctrine-instantiator.spec b/php-doctrine-instantiator.spec
index 7768e84..3f8966f 100644
--- a/php-doctrine-instantiator.spec
+++ b/php-doctrine-instantiator.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-instantiator
#
-# Copyright (c) 2014-2022 Remi Collet
+# Copyright (c) 2014-2023 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -9,7 +9,7 @@
# bootstrap needed when rebuilding PHPUnit for new major version
%global bootstrap 0
-%global gh_commit 10dcfce151b967d20fde1b34ae6640712c3891bc
+%global gh_commit 0a0fa9780f5d4e507415a065172d26a98d02047b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project instantiator
@@ -21,7 +21,7 @@
%endif
Name: php-doctrine-instantiator
-Version: 1.4.1
+Version: 1.5.0
Release: 1%{?dist}
Summary: Instantiate objects in PHP without invoking their constructors
@@ -95,7 +95,7 @@ EOF
: Run test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=vendor/autoload.php \
@@ -119,6 +119,9 @@ exit $ret
%changelog
+* Tue Jan 3 2023 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
* Thu Mar 3 2022 Remi Collet <remi@remirepo.net> - 1.4.1-1
- update to 1.4.1