summaryrefslogtreecommitdiffstats
path: root/php-doctrine-instantiator.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-12 08:08:15 +0100
committerRemi Collet <remi@remirepo.net>2020-11-12 08:08:15 +0100
commit6998a0cd2b6b1ce7ecd62d993284535d346957dc (patch)
treef2698d58ec1c7f35e3d21f7c2c6648903bb7bcc8 /php-doctrine-instantiator.spec
parent625a2e397c52293a42d50f1c9ed98e7ea5344d91 (diff)
update to 1.4.0
Diffstat (limited to 'php-doctrine-instantiator.spec')
-rw-r--r--php-doctrine-instantiator.spec23
1 files changed, 16 insertions, 7 deletions
diff --git a/php-doctrine-instantiator.spec b/php-doctrine-instantiator.spec
index f6a2688..b373f86 100644
--- a/php-doctrine-instantiator.spec
+++ b/php-doctrine-instantiator.spec
@@ -9,7 +9,7 @@
# bootstrap needed when rebuilding PHPUnit for new major version
%global bootstrap 0
-%global gh_commit f350df0268e904597e3bd9c4685c53e0e333feea
+%global gh_commit d56bf6102915de5702778fe20f2de3b2fe570b5b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project instantiator
@@ -21,7 +21,7 @@
%endif
Name: php-doctrine-instantiator
-Version: 1.3.1
+Version: 1.4.0
Release: 1%{?dist}
Summary: Instantiate objects in PHP without invoking their constructors
@@ -38,7 +38,12 @@ BuildRequires: php-phar
BuildRequires: php-pdo
BuildRequires: php-reflection
BuildRequires: php-spl
-BuildRequires: phpunit8
+%if 0%{?fedora} >=31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+%else
+%global phpunit %{_bindir}/phpunit8
+%endif
+BuildRequires: %{phpunit}
%endif
# From composer.json
@@ -91,10 +96,11 @@ EOF
: Run test suite
ret=0
-for cmd in php php73 php74 php80; do
- if which $cmd; then
- $cmd -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/php" \
- %{_bindir}/phpunit8 \
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/php" \
+ ${2:-%{_bindir}/phpunit9} \
--verbose || ret=1
fi
done
@@ -114,6 +120,9 @@ exit $ret
%changelog
+* Thu Nov 12 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+
* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1 (no change)
- switch to phpunit8