summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-04 11:35:58 +0200
committerRemi Collet <remi@remirepo.net>2017-08-04 11:35:58 +0200
commitc3a91b6ff7dee91504920fccc9a822b17e60470b (patch)
treed261917ef463d776ee6e81ee3363e7e57c4318c8
parentb4615575679e68c888e9074f9da3be5e46f485e0 (diff)
v1.1.1 (PHP 7.1+)
-rw-r--r--.gitignore7
-rw-r--r--composer.json45
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-doctrine-instantiator.spec72
4 files changed, 120 insertions, 32 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..403ee8e
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,45 @@
+{
+ "name": "doctrine/instantiator",
+ "description": "A small, lightweight utility to instantiate objects in PHP without invoking their constructors",
+ "type": "library",
+ "license": "MIT",
+ "homepage": "https://github.com/doctrine/instantiator",
+ "keywords": [
+ "instantiate",
+ "constructor"
+ ],
+ "authors": [
+ {
+ "name": "Marco Pivetta",
+ "email": "ocramius@gmail.com",
+ "homepage": "http://ocramius.github.com/"
+ }
+ ],
+ "require": {
+ "php": "^7.1"
+ },
+ "require-dev": {
+ "ext-phar": "*",
+ "ext-pdo": "*",
+ "phpunit/phpunit": "^6.2.3",
+ "squizlabs/php_codesniffer": "^3.0.2",
+ "athletic/athletic": "~0.1.8"
+ },
+ "autoload": {
+ "psr-4": {
+ "Doctrine\\Instantiator\\": "src/Doctrine/Instantiator/"
+ }
+ },
+ "autoload-dev": {
+ "psr-0": {
+ "DoctrineTest\\InstantiatorPerformance\\": "tests",
+ "DoctrineTest\\InstantiatorTest\\": "tests",
+ "DoctrineTest\\InstantiatorTestAsset\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.2.x-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-doctrine-instantiator.spec b/php-doctrine-instantiator.spec
index dbc226d..b6fdf3f 100644
--- a/php-doctrine-instantiator.spec
+++ b/php-doctrine-instantiator.spec
@@ -9,42 +9,46 @@
# bootstrap needed when rebuilding PHPUnit for new major version
%global bootstrap 0
-%global gh_commit 8e884e78f9f0eb1329e445619e04456e64d8051d
+%global gh_commit 185b8868aa9bf7159f5f953ed5afb2d7fcdc3bda
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project instantiator
%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests 0%{?_with_tests:1}
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%global with_tests 0%{!?_without_tests:1}
%endif
Name: php-doctrine-instantiator
-Version: 1.0.5
+Version: 1.1.0
Release: 1%{?dist}
Summary: Instantiate objects in PHP without invoking their constructors
Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: %{_bindir}/phpab
+BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: php(language) >= 5.3
+BuildRequires: php(language) >= 7.1
BuildRequires: php-phar
BuildRequires: php-pdo
BuildRequires: php-reflection
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: php-spl
+BuildRequires: phpunit6 >= 6.2.3
%endif
# From composer.json
-# "php": ">=5.3,<8.0-DEV"
-Requires: php(language) >= 5.3
-# From phpcompatinfo report for version 1.0.5
+# "php": "^7.1"
+Requires: php(language) >= 7.1
+# From phpcompatinfo report for version 1.1.0
Requires: php-reflection
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
Provides: php-composer(doctrine/instantiator) = %{version}
@@ -62,45 +66,43 @@ instantiating PHP classes.
: Generate a simple autoloader
%{_bindir}/phpab \
--output src/Doctrine/Instantiator/autoload.php \
+ --template fedora \
src/Doctrine/Instantiator
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{_datadir}/php
cp -pr src/* %{buildroot}%{_datadir}/php
%check
%if %{with_tests}
-# "src" directory only needed for EPEL-6
: Generate autoloader
+mkdir vendor
%{_bindir}/phpab \
- --basedir $PWD \
- --output autoload.php \
- src tests
+ --output vendor/autoload.php \
+ --template fedora \
+ tests
+cat << 'EOF' | tee -a vendor/autoload.php
+require "%{buildroot}%{_datadir}/php/Doctrine/Instantiator/autoload.php";
+EOF
-sed -e '/log/d' phpunit.xml.dist >phpunit.xml
-
-# "pear" directory only needed for EPEL-6
: Run test suite
-%{_bindir}/php \
- -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/pear:%{_datadir}/php" \
- %{_bindir}/phpunit \
- --include-path=%{buildroot}%{_datadir}/php \
- --bootstrap autoload.php \
- --verbose
+ret=0
+for cmd in php php71 php72; do
+ if which $cmd; then
+ $cmd -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/php" \
+ %{_bindir}/phpunit6 \
+ --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md composer.json
@@ -109,6 +111,12 @@ rm -rf %{buildroot}
%changelog
+* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- Update to 1.1.0
+- raise dependency on PHP 7.1
+- switch to phpunit6
+- use git snapshot for sources
+
* Mon Jun 15 2015 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
- update to 1.0.5
- improve test suite during the build
@@ -123,4 +131,4 @@ rm -rf %{buildroot}
- update to 1.0.3
* Mon Aug 25 2014 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
-- initial package, version 1.0.2 \ No newline at end of file
+- initial package, version 1.0.2