summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-02 08:38:25 +0200
committerRemi Collet <remi@remirepo.net>2020-06-02 08:38:25 +0200
commit625a2e397c52293a42d50f1c9ed98e7ea5344d91 (patch)
tree209e4128a22cc8473717390bf274a3debaa1ee52
parented0cce838da60d00afb3dc95b5d6b3a1241d6e48 (diff)
update to 1.3.1 (no change)
switch to phpunit8
-rw-r--r--composer.json7
-rw-r--r--php-doctrine-instantiator.spec38
2 files changed, 21 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 9002a91..a84baa7 100644
--- a/composer.json
+++ b/composer.json
@@ -15,8 +15,13 @@
"homepage": "http://ocramius.github.com/"
}
],
+ "config": {
+ "platform": {
+ "php": "7.1.27"
+ }
+ },
"require": {
- "php": "^7.1"
+ "php": "^7.1 || ^8.0"
},
"require-dev": {
"ext-phar": "*",
diff --git a/php-doctrine-instantiator.spec b/php-doctrine-instantiator.spec
index 4588941..f6a2688 100644
--- a/php-doctrine-instantiator.spec
+++ b/php-doctrine-instantiator.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-instantiator
#
-# Copyright (c) 2014-2019 Remi Collet
+# Copyright (c) 2014-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -9,29 +9,20 @@
# bootstrap needed when rebuilding PHPUnit for new major version
%global bootstrap 0
-%global gh_commit ae466f726242e637cebdd526a7d991b9433bacf1
+%global gh_commit f350df0268e904597e3bd9c4685c53e0e333feea
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project instantiator
+%global major %nil
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-# remirepo:1
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
Name: php-doctrine-instantiator
+Version: 1.3.1
Release: 1%{?dist}
-%global major %nil
-# remirepo:6
-%else
-Name: php-doctrine-instantiator11
-Release: 1%{?dist}
-%global major 11
-%global with_tests 0
-%endif
-Version: 1.3.0
Summary: Instantiate objects in PHP without invoking their constructors
License: MIT
@@ -47,11 +38,11 @@ BuildRequires: php-phar
BuildRequires: php-pdo
BuildRequires: php-reflection
BuildRequires: php-spl
-BuildRequires: phpunit6
+BuildRequires: phpunit8
%endif
# From composer.json
-# "php": "^7.1"
+# "php": "^7.1 || ^8.0"
Requires: php(language) >= 7.1
# From phpcompatinfo report for version 1.1.0
Requires: php-reflection
@@ -59,15 +50,9 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-# remirepo:1
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
Obsoletes: php-doctrine-instantiator11 < %{version}-%{release}
Provides: php-doctrine-instantiator11 = %{version}-%{release}
Provides: php-composer(doctrine/instantiator) = %{version}
-# remirepo:3
-%else
-Requires: php-doctrine-instantiator
-%endif
%description
@@ -106,10 +91,10 @@ EOF
: Run test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/php" \
- %{_bindir}/phpunit6 \
+ %{_bindir}/phpunit8 \
--verbose || ret=1
fi
done
@@ -129,6 +114,13 @@ exit $ret
%changelog
+* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- update to 1.3.1 (no change)
+- switch to phpunit8
+
+* Wed Jan 22 2020 Remi Collet <remi@remirepo.net> - 1.3.0-2
+- obsolete php-doctrine-instantiator11
+
* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 1.3.0-1
- update to 1.3.0