summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-03-25 12:35:39 +0100
committerRemi Collet <remi@remirepo.net>2019-03-25 12:35:39 +0100
commit57ab4f51a6079b1a9eab5cb83c2d402567e7c07f (patch)
treea8dfa19525c4ead4c92f81d91dddb8f01bc4bb43
parentf0458cedda27c8528d98bcc1eb78b8ffa4a7935e (diff)
v1.2.0
-rw-r--r--composer.json10
-rw-r--r--php-doctrine-instantiator.spec21
2 files changed, 20 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 403ee8e..9002a91 100644
--- a/composer.json
+++ b/composer.json
@@ -3,7 +3,7 @@
"description": "A small, lightweight utility to instantiate objects in PHP without invoking their constructors",
"type": "library",
"license": "MIT",
- "homepage": "https://github.com/doctrine/instantiator",
+ "homepage": "https://www.doctrine-project.org/projects/instantiator.html",
"keywords": [
"instantiate",
"constructor"
@@ -21,9 +21,11 @@
"require-dev": {
"ext-phar": "*",
"ext-pdo": "*",
- "phpunit/phpunit": "^6.2.3",
- "squizlabs/php_codesniffer": "^3.0.2",
- "athletic/athletic": "~0.1.8"
+ "doctrine/coding-standard": "^6.0",
+ "phpbench/phpbench": "^0.13",
+ "phpstan/phpstan-phpunit": "^0.11",
+ "phpstan/phpstan-shim": "^0.11",
+ "phpunit/phpunit": "^7.0"
},
"autoload": {
"psr-4": {
diff --git a/php-doctrine-instantiator.spec b/php-doctrine-instantiator.spec
index a96043a..0df9a7b 100644
--- a/php-doctrine-instantiator.spec
+++ b/php-doctrine-instantiator.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-instantiator
#
-# Copyright (c) 2014-2017 Remi Collet
+# Copyright (c) 2014-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -9,7 +9,7 @@
# bootstrap needed when rebuilding PHPUnit for new major version
%global bootstrap 0
-%global gh_commit 185b8868aa9bf7159f5f953ed5afb2d7fcdc3bda
+%global gh_commit a2c590166b2133a4633738648b6b064edae0814a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project instantiator
@@ -19,20 +19,21 @@
%global with_tests 0%{!?_without_tests:1}
%endif
+# remirepo:1
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
Name: php-doctrine-instantiator
-Release: 3%{?dist}
+Release: 1%{?dist}
%global major %nil
+# remirepo:6
%else
Name: php-doctrine-instantiator11
Release: 1%{?dist}
%global major 11
%global with_tests 0
%endif
-Version: 1.1.0
+Version: 1.2.0
Summary: Instantiate objects in PHP without invoking their constructors
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: php-%{gh_owner}-%{gh_project}-%{version}-%{gh_short}.tgz
@@ -46,7 +47,7 @@ BuildRequires: php-phar
BuildRequires: php-pdo
BuildRequires: php-reflection
BuildRequires: php-spl
-BuildRequires: phpunit6 >= 6.2.3
+BuildRequires: phpunit6
%endif
# From composer.json
@@ -58,10 +59,12 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
+# remirepo:1
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
Obsoletes: php-doctrine-instantiator11 < %{version}-%{release}
Provides: php-doctrine-instantiator11 = %{version}-%{release}
Provides: php-composer(doctrine/instantiator) = %{version}
+# remirepo:3
%else
Requires: php-doctrine-instantiator
%endif
@@ -103,7 +106,7 @@ EOF
: Run test suite
ret=0
-for cmd in php php71 php72; do
+for cmd in php php71 php72 php73; do
if which $cmd; then
$cmd -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/php" \
%{_bindir}/phpunit6 \
@@ -117,6 +120,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md composer.json
@@ -125,6 +129,9 @@ exit $ret
%changelog
+* Mon Mar 25 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 1.1.0-3
- allow parallel installation of 1.0 and 1.1