summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-03 14:00:39 +0100
committerRemi Collet <remi@php.net>2022-03-03 14:00:39 +0100
commit3b6ac469b883cc70e187250e1027215f8e554362 (patch)
tree723b65621627c9789ced6ec9c3a28a844f6ca9f0
parent46cf5d5205afbae45d64974a287485616ef33fae (diff)
update to 1.4.1
-rw-r--r--composer.json16
-rw-r--r--php-doctrine-instantiator.spec20
2 files changed, 22 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 1ce3473..4fba95c 100644
--- a/composer.json
+++ b/composer.json
@@ -21,11 +21,12 @@
"require-dev": {
"ext-phar": "*",
"ext-pdo": "*",
- "doctrine/coding-standard": "^8.0",
- "phpbench/phpbench": "^0.13 || 1.0.0-alpha2",
- "phpstan/phpstan": "^0.12",
- "phpstan/phpstan-phpunit": "^0.12",
- "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
+ "doctrine/coding-standard": "^9",
+ "phpbench/phpbench": "^0.16 || ^1",
+ "phpstan/phpstan": "^1.4",
+ "phpstan/phpstan-phpunit": "^1",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+ "vimeo/psalm": "^4.22"
},
"autoload": {
"psr-4": {
@@ -38,5 +39,10 @@
"DoctrineTest\\InstantiatorTest\\": "tests",
"DoctrineTest\\InstantiatorTestAsset\\": "tests"
}
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
}
}
diff --git a/php-doctrine-instantiator.spec b/php-doctrine-instantiator.spec
index cb8816c..7768e84 100644
--- a/php-doctrine-instantiator.spec
+++ b/php-doctrine-instantiator.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-instantiator
#
-# Copyright (c) 2014-2020 Remi Collet
+# Copyright (c) 2014-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -9,7 +9,7 @@
# bootstrap needed when rebuilding PHPUnit for new major version
%global bootstrap 0
-%global gh_commit d56bf6102915de5702778fe20f2de3b2fe570b5b
+%global gh_commit 10dcfce151b967d20fde1b34ae6640712c3891bc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project instantiator
@@ -21,7 +21,7 @@
%endif
Name: php-doctrine-instantiator
-Version: 1.4.0
+Version: 1.4.1
Release: 1%{?dist}
Summary: Instantiate objects in PHP without invoking their constructors
@@ -38,11 +38,7 @@ BuildRequires: php-phar
BuildRequires: php-pdo
BuildRequires: php-reflection
BuildRequires: php-spl
-%if 0%{?fedora} >=31 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
-%else
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: %{phpunit}
%endif
@@ -92,14 +88,17 @@ mkdir vendor
tests
cat << 'EOF' | tee -a vendor/autoload.php
require "%{buildroot}%{_datadir}/php/Doctrine/Instantiator/autoload.php";
+Fedora\Autoloader\Autoload::addPsr0('DoctrineTest\\InstantiatorPerformance\\', dirname(__DIR__).'/tests');
+Fedora\Autoloader\Autoload::addPsr0('DoctrineTest\\InstantiatorTest\\', dirname(__DIR__).'/tests');
+Fedora\Autoloader\Autoload::addPsr0('DoctrineTest\\InstantiatorTestAsset\\', dirname(__DIR__).'/tests');
EOF
: Run test suite
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
- $1 -d include_path=".:%{buildroot}%{_datadir}/php:%{_datadir}/php" \
+ $1 -d auto_prepend_file=vendor/autoload.php \
${2:-%{_bindir}/phpunit9} \
--verbose || ret=1
fi
@@ -120,6 +119,9 @@ exit $ret
%changelog
+* Thu Mar 3 2022 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- update to 1.4.1
+
* Thu Nov 12 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0 (no change)
- switch to phpunit9