summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-25 10:03:00 +0200
committerRemi Collet <remi@php.net>2021-10-25 10:03:00 +0200
commit6b262f4ef65dcd9f62f52b02c2bd5f9aa6ed1440 (patch)
treed491e1fa83018e88222da550d3130e26f274d450
parent3633d77a905546f47d697aa99a084d7463d0fca5 (diff)
update to 2.0.4
switch to phpunit9
-rw-r--r--composer.json16
-rw-r--r--php-doctrine-inflector2.spec18
2 files changed, 17 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index 0cd85e5..f08fdc3 100644
--- a/composer.json
+++ b/composer.json
@@ -16,11 +16,12 @@
"php": "^7.2 || ^8.0"
},
"require-dev": {
- "doctrine/coding-standard": "^7.0",
- "phpstan/phpstan": "^0.11",
- "phpstan/phpstan-phpunit": "^0.11",
- "phpstan/phpstan-strict-rules": "^0.11",
- "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
+ "doctrine/coding-standard": "^8.2",
+ "phpstan/phpstan": "^0.12",
+ "phpstan/phpstan-phpunit": "^0.12",
+ "phpstan/phpstan-strict-rules": "^0.12",
+ "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0",
+ "vimeo/psalm": "^4.10"
},
"autoload": {
"psr-4": {
@@ -31,10 +32,5 @@
"psr-4": {
"Doctrine\\Tests\\Inflector\\": "tests/Doctrine/Tests/Inflector"
}
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.0.x-dev"
- }
}
}
diff --git a/php-doctrine-inflector2.spec b/php-doctrine-inflector2.spec
index feabf2d..052eb54 100644
--- a/php-doctrine-inflector2.spec
+++ b/php-doctrine-inflector2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-doctrine-inflector2
#
-# Copyright (c) 2013-2020 Shawn Iwinski, Remi Collet
+# Copyright (c) 2013-2021 Shawn Iwinski, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,9 +10,9 @@
%global github_owner doctrine
%global github_name inflector
-%global github_version 2.0.3
+%global github_version 2.0.4
%global major 2
-%global github_commit 9cf661f4eb38f7c881cac67c75ea9b00bf97b210
+%global github_commit 8b7ff3e4b7de6b2c84da85637b59fd2880ecaa89
%global composer_vendor doctrine
%global composer_project inflector
@@ -42,15 +42,15 @@ BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
-BuildRequires: phpunit8
+BuildRequires: phpunit9
BuildRequires: php(language) >= %{php_min_ver}
## phpcompatinfo (computed from version 2.0.1)
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
-%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
@@ -96,9 +96,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php72 php73 php74 php80; do
+for PHP_EXEC in "" php73 php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- phpunit8 --verbose --bootstrap bootstrap.php \
+ phpunit9 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -119,6 +119,10 @@ exit $RETURN_CODE
%changelog
+* Mon Oct 25 2021 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+- switch to phpunit9
+
* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 2.0.3-1
- update to 2.0.3