summaryrefslogtreecommitdiffstats
path: root/php-doctrine-inflector.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-inflector.spec')
-rw-r--r--php-doctrine-inflector.spec30
1 files changed, 19 insertions, 11 deletions
diff --git a/php-doctrine-inflector.spec b/php-doctrine-inflector.spec
index 44837cc..5368b6c 100644
--- a/php-doctrine-inflector.spec
+++ b/php-doctrine-inflector.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-inflector
#
-# Copyright (c) 2013-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,14 +12,14 @@
%global github_owner doctrine
%global github_name inflector
-%global github_version 1.1.0
-%global github_commit 90b2128806bfde671b6952ab8bea493942c1fdae
+%global github_version 1.3.0
+%global github_commit 5527a48b7313d15261292c149e55e26eae771b0a
%global composer_vendor doctrine
%global composer_project inflector
-# "php": ">=5.3.2"
-%global php_min_ver 5.3.2
+# "php": "^7.1"
+%global php_min_ver 7.1
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -28,13 +28,17 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 4%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Common string manipulations with regard to casing and singular/plural rules
Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests.
+# Run php-doctrine-inflector-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
@@ -42,16 +46,15 @@ BuildArch: noarch
## composer.json
BuildRequires: %{_bindir}/phpunit
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 1.1.0)
+## phpcompatinfo (computed from version 1.3.0)
BuildRequires: php-pcre
-BuildRequires: php-spl
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.1.0)
+# phpcompatinfo (computed from version 1.3.0)
Requires: php-pcre
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -101,7 +104,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" php71 php72; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -124,6 +127,11 @@ exit $RETURN_CODE
%changelog
+* Sun Apr 22 2018 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.0-1
+- Update to 1.3.0 (RHBZ #1473993)
+- Add get source script
+- Add composer.json to repo
+
* Sat May 13 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.0-4
- Switch autoloader to php-composer(fedora/autoloader)
- Test with SCLs if available