summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-11 14:47:41 +0200
committerRemi Collet <remi@remirepo.net>2020-05-11 14:47:41 +0200
commitc8b5c7b28fd74f4ec9312900b22b92bd779d8e1f (patch)
tree73c5139298edda3a961b68540e8ed7e9d5432bba
parentade8d174c64af30f2d8b78e2c31f4d69a203d27b (diff)
update to 1.4.1
raise dependency on PHP 7.2 switch to phpunit8 switch to classmap autoloader
-rw-r--r--composer.json26
-rw-r--r--php-doctrine-inflector.spec37
2 files changed, 35 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index 2189ff1..aceeb8d 100644
--- a/composer.json
+++ b/composer.json
@@ -1,9 +1,9 @@
{
"name": "doctrine/inflector",
"type": "library",
- "description": "Common String Manipulations with regard to casing and singular/plural rules.",
- "keywords": ["string", "inflection", "singularize", "pluralize"],
- "homepage": "http://www.doctrine-project.org",
+ "description": "PHP Doctrine Inflector is a small library that can perform string manipulations with regard to upper/lowercase and singular/plural forms of words.",
+ "keywords": ["php", "strings", "words", "manipulation", "inflector", "inflection", "uppercase", "lowercase", "singular", "plural"],
+ "homepage": "https://www.doctrine-project.org/projects/inflector.html",
"license": "MIT",
"authors": [
{"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
@@ -13,20 +13,30 @@
{"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
],
"require": {
- "php": "^7.1"
+ "php": "^7.2"
},
"require-dev": {
- "phpunit/phpunit": "^6.2"
+ "doctrine/coding-standard": "^7.0",
+ "phpstan/phpstan": "^0.11",
+ "phpstan/phpstan-phpunit": "^0.11",
+ "phpstan/phpstan-strict-rules": "^0.11",
+ "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
},
"autoload": {
- "psr-4": { "Doctrine\\Common\\Inflector\\": "lib/Doctrine/Common/Inflector" }
+ "psr-4": {
+ "Doctrine\\Common\\Inflector\\": "lib/Doctrine/Common/Inflector",
+ "Doctrine\\Inflector\\": "lib/Doctrine/Inflector"
+ }
},
"autoload-dev": {
- "psr-4": { "Doctrine\\Tests\\Common\\Inflector\\": "tests/Doctrine/Tests/Common/Inflector" }
+ "psr-4": {
+ "Doctrine\\Tests\\Common\\Inflector\\": "tests/Doctrine/Tests/Common/Inflector",
+ "Doctrine\\Tests\\Inflector\\": "tests/Doctrine/Tests/Inflector"
+ }
},
"extra": {
"branch-alias": {
- "dev-master": "1.3.x-dev"
+ "dev-master": "2.0.x-dev"
}
}
}
diff --git a/php-doctrine-inflector.spec b/php-doctrine-inflector.spec
index c450363..5cdbc65 100644
--- a/php-doctrine-inflector.spec
+++ b/php-doctrine-inflector.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-inflector
#
-# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,14 +12,14 @@
%global github_owner doctrine
%global github_name inflector
-%global github_version 1.3.1
-%global github_commit ec3a55242203ffa6a4b27c58176da97ff0a7aec1
+%global github_version 1.4.1
+%global github_commit 4111f6853aea6f28b2b1dcfdde83d12dd3d5e6e3
%global composer_vendor doctrine
%global composer_project inflector
-# "php": "^7.1"
-%global php_min_ver 7.1
+# "php": "^7.2"
+%global php_min_ver 7.2
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -43,12 +43,12 @@ BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: phpunit8
BuildRequires: php(language) >= %{php_min_ver}
## phpcompatinfo (computed from version 1.3.0)
BuildRequires: php-pcre
# Autoloader
-BuildRequires: php-composer(fedora/autoloader)
+BuildRequires: php-fedora-autoloader-devel
%endif
# composer.json
@@ -74,16 +74,7 @@ Autoloader: %{phpdir}/Doctrine/Common/Inflector/autoload.php
%build
: Create autoloader
-cat <<'AUTOLOAD' | tee lib/Doctrine/Common/Inflector/autoload.php
-<?php
-/**
- * Autoloader for %{name} and its' dependencies
- * (created by %{name}-%{version}-%{release}).
- */
-require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
-
-\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Common\\Inflector\\', __DIR__);
-AUTOLOAD
+phpab --template fedora --output lib/Doctrine/Common/Inflector/autoload.php lib
%install
@@ -102,10 +93,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" php71 php72 php73 php74; do
+for PHP_EXEC in "" php72 php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ phpunit8 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -123,9 +113,16 @@ exit $RETURN_CODE
%dir %{phpdir}/Doctrine
%dir %{phpdir}/Doctrine/Common
%{phpdir}/Doctrine/Common/Inflector
+ %{phpdir}/Doctrine/Inflector
%changelog
+* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- update to 1.4.1
+- raise dependency on PHP 7.2
+- switch to phpunit8
+- switch to classmap autoloader
+
* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1