summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-22 11:23:05 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-22 11:23:05 +0200
commitae1bfb84ffae5a9599de01a5f3da5b7a90882c2a (patch)
tree3d89d431125e913fb91921fa5bb54e4001e56651
parent1dfb9a5f45e1bb9a0b632a79935fea2a7fd736ca (diff)
php-doctrine-inflector: rawhide changes
-rw-r--r--php-doctrine-inflector.spec54
1 files changed, 41 insertions, 13 deletions
diff --git a/php-doctrine-inflector.spec b/php-doctrine-inflector.spec
index c1393ef..109c628 100644
--- a/php-doctrine-inflector.spec
+++ b/php-doctrine-inflector.spec
@@ -1,16 +1,33 @@
-%global github_owner doctrine
-%global github_name inflector
-%global github_version 1.0
-%global github_commit a81c334f2764b09e2f13a55cfd8fe3233946f728
+#
+# RPM spec file for php-doctrine-inflector
+#
+# Copyright (c) 2013-2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner doctrine
+%global github_name inflector
+%global github_version 1.0
+%global github_commit a81c334f2764b09e2f13a55cfd8fe3233946f728
# Additional commits after v1.0 tag
-%global github_release .20131221git%(c=%{github_commit}; echo ${c:0:7})
+%global github_release .20131221git%(c=%{github_commit}; echo ${c:0:7})
+
+%global composer_vendor doctrine
+%global composer_project inflector
# "php": ">=5.3.2"
-%global php_min_ver 5.3.2
+%global php_min_ver 5.3.2
+
+# Build using "--without tests" to disable tests
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-Name: php-%{github_owner}-%{github_name}
+Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 4%{?github_release}%{?dist}
Summary: Common string manipulations with regard to casing and singular/plural rules
Group: Development/Libraries
@@ -20,24 +37,29 @@ Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{githu
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+BuildRequires: php-phpunit-PHPUnit
# For tests: phpcompatinfo (computed from v1.0 git commit a81c334f2764b09e2f13a55cfd8fe3233946f728)
BuildRequires: php-pcre
BuildRequires: php-spl
+%endif
Requires: php(language) >= %{php_min_ver}
# phpcompatinfo (computed from v1.0 git commit a81c334f2764b09e2f13a55cfd8fe3233946f728)
Requires: php-pcre
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
%description
Doctrine Inflector is a small library that can perform string manipulations
with regard to upper-/lowercase and singular/plural forms of words.
%prep
-%setup -q -n %{github_name}-%{github_commit}
+%setup -qn %{github_name}-%{github_commit}
%build
@@ -51,12 +73,14 @@ cp -rp lib/* %{buildroot}/%{_datadir}/php/
%check
+%if %{with_tests}
# Create PHPUnit config w/ colors turned off
-cat phpunit.xml.dist \
- | sed 's/colors="true"/colors="false"/' \
- > phpunit.xml
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%{_bindir}/phpunit --include-path ./lib:./tests -d date.timezone="UTC"
+%else
+: Tests skipped
+%endif
%clean
@@ -72,6 +96,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0-4.20131221gita81c334
+- Added php-composer(%%{composer_vendor}/%%{composer_project}) virtual provide
+- Added option to build without tests ("--without tests")
+
* Sat Jan 11 2014 Remi Collet <rpms@famillecollet.com> 1.0-2.20131221gita81c334
- backport for remi repo