summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json68
-rw-r--r--php-doctrine-doctrine-cache-bundle.spec125
2 files changed, 87 insertions, 106 deletions
diff --git a/composer.json b/composer.json
index 2b9696c..720fe3b 100644
--- a/composer.json
+++ b/composer.json
@@ -1,57 +1,57 @@
{
- "name": "doctrine/doctrine-cache-bundle",
- "homepage": "https://www.doctrine-project.org",
- "description": "Symfony Bundle for Doctrine Cache",
- "keywords": ["cache", "caching"],
- "type": "symfony-bundle",
- "license": "MIT",
+ "name": "doctrine/doctrine-cache-bundle",
+ "homepage": "https://www.doctrine-project.org",
+ "description": "Symfony Bundle for Doctrine Cache",
+ "keywords": ["cache", "caching"],
+ "type": "symfony-bundle",
+ "license": "MIT",
"authors": [
{
- "name": "Fabien Potencier",
- "email": "fabien@symfony.com"
+ "name": "Fabien Potencier",
+ "email": "fabien@symfony.com"
},
{
- "name": "Benjamin Eberlei",
- "email": "kontakt@beberlei.de"
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
},
{
- "name": "Fabio B. Silva",
- "email": "fabio.bat.silva@gmail.com"
+ "name": "Fabio B. Silva",
+ "email": "fabio.bat.silva@gmail.com"
},
{
- "name": "Guilherme Blanco",
- "email": "guilhermeblanco@hotmail.com"
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@hotmail.com"
},
{
- "name": "Symfony Community",
+ "name": "Symfony Community",
"homepage": "http://symfony.com/contributors"
},
{
- "name": "Doctrine Project",
+ "name": "Doctrine Project",
"homepage": "http://www.doctrine-project.org/"
}
],
"require": {
- "php": ">=5.3.2",
- "symfony/doctrine-bridge": "~2.7|~3.3|~4.0",
- "doctrine/inflector": "~1.0",
- "doctrine/cache": "^1.4.2"
+ "php": "^7.1",
+ "symfony/doctrine-bridge": "^3.4|^4.0",
+ "doctrine/inflector": "^1.0",
+ "doctrine/cache": "^1.4.2"
},
"require-dev": {
- "phpunit/phpunit": "~4.8.36|~5.6|~6.5|~7.0",
- "symfony/phpunit-bridge": "~2.7|~3.3|~4.0",
- "symfony/yaml": "~2.7|~3.3|~4.0",
- "symfony/validator": "~2.7|~3.3|~4.0",
- "symfony/console": "~2.7|~3.3|~4.0",
- "symfony/finder": "~2.7|~3.3|~4.0",
- "symfony/framework-bundle": "~2.7|~3.3|~4.0",
- "symfony/security-acl": "~2.7|~3.3",
- "instaclick/coding-standard": "~1.1",
- "satooshi/php-coveralls": "^1.0",
- "squizlabs/php_codesniffer": "~1.5",
+ "phpunit/phpunit": "^7.0",
+ "symfony/phpunit-bridge": "^3.4|^4.0",
+ "symfony/yaml": "^3.4|^4.0",
+ "symfony/validator": "^3.4|^4.0",
+ "symfony/console": "^3.4|^4.0",
+ "symfony/finder": "^3.4|^4.0",
+ "symfony/framework-bundle": "^3.4|^4.0",
+ "symfony/security-acl": "^2.8",
+ "instaclick/coding-standard": "~1.1",
+ "satooshi/php-coveralls": "^1.0",
+ "squizlabs/php_codesniffer": "~1.5",
"instaclick/object-calisthenics-sniffs": "dev-master",
- "instaclick/symfony2-coding-standard": "dev-remaster",
- "predis/predis": "~0.8"
+ "instaclick/symfony2-coding-standard": "dev-remaster",
+ "predis/predis": "~0.8"
},
"suggest": {
"symfony/security-acl": "For using this bundle to cache ACLs"
@@ -67,7 +67,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.3.x-dev"
+ "dev-master": "1.4.x-dev"
}
}
}
diff --git a/php-doctrine-doctrine-cache-bundle.spec b/php-doctrine-doctrine-cache-bundle.spec
index 313536c..5c91f41 100644
--- a/php-doctrine-doctrine-cache-bundle.spec
+++ b/php-doctrine-doctrine-cache-bundle.spec
@@ -12,33 +12,32 @@
%global github_owner doctrine
%global github_name DoctrineCacheBundle
-%global github_version 1.3.5
-%global github_commit 5514c90d9fb595e1095e6d66ebb98ce9ef049927
+%global github_version 1.4.0
+%global github_commit 6bee2f9b339847e8a984427353670bad4e7bdccb
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor doctrine
%global composer_project doctrine-cache-bundle
-# "php": ">=5.3.2"
-%global php_min_ver 5.3.2
+# "php": "^7.1"
+%global php_min_ver 7.1
# "doctrine/cache": "^1.4.2"
%global cache_min_ver 1.4.2
%global cache_max_ver 2.0
# "doctrine/inflector": "~1.0"
%global inflector_min_ver 1.0
%global inflector_max_ver 2.0
-# "symfony/doctrine-bridge": "~2.7|~3.3|~4.0"
-# "symfony/yaml": "~2.7|~3.3|~4.0",
-# "symfony/validator": "~2.7|~3.3|~4.0",
-# "symfony/console": "~2.7|~3.3|~4.0",
-# "symfony/finder": "~2.7|~3.3|~4.0",
-# "symfony/framework-bundle": "~2.7|~3.3|~4.0",
-# NOTE: Min version not 2.3 because autoloader required
-%global symfony_min_ver 2.7.1
+# "symfony/doctrine-bridge": "^3.4|^4.0"
+# "symfony/yaml": "^3.4|^4.0",
+# "symfony/validator": "^3.4|^4.0",
+# "symfony/console": "^3.4|^4.0",
+# "symfony/finder": "^3.4|^4.0",
+# "symfony/framework-bundle": "^3.4|^4.0",
+%global symfony_min_ver 3.4
%global symfony_max_ver 5
-# "symfony/security-acl": "~2.3|~3.0",
-%global secacl_min_ver 2.2
-%global secacl_max_ver 4
+# "symfony/security-acl": "^2.8",
+%global secacl_min_ver 2.8
+%global secacl_max_ver 3
# Build using "--with tests" to enable tests
%global with_tests 0%{?_with_tests:1}
@@ -47,7 +46,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 5%{?dist}
+Release: 1%{?dist}
Summary: Symfony2 Bundle for Doctrine Cache
License: MIT
@@ -63,6 +62,7 @@ BuildRequires: php(language) >= %{php_min_ver}
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
BuildRequires: (php-composer(doctrine/inflector) >= %{inflector_min_ver} with php-composer(doctrine/inflector) < %{inflector_max_ver})
+BuildRequires: (php-composer(symfony/security-acl) >= %{secacl_min_ver} with php-composer(symfony/security-acl) < %{secacl_max_ver})
# ensure we use same version of all components
BuildRequires: php-symfony4-console
BuildRequires: php-symfony4-doctrine-bridge
@@ -70,29 +70,19 @@ BuildRequires: php-symfony4-finder
BuildRequires: php-symfony4-framework-bundle
BuildRequires: php-symfony4-validator
BuildRequires: php-symfony4-yaml
-BuildRequires: phpunit7
-%global phpunit %{_bindir}/phpunit7
-%else
-BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
-BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
-BuildRequires: php-composer(doctrine/inflector) < %{inflector_max_ver}
-BuildRequires: php-composer(doctrine/inflector) >= %{inflector_min_ver}
-BuildRequires: php-symfony-console
-BuildRequires: php-symfony-doctrine-bridge
-BuildRequires: php-symfony-finder
-BuildRequires: php-symfony-framework-bundle
-BuildRequires: php-symfony-validator
-BuildRequires: php-symfony-yaml
-BuildRequires: php-composer(phpunit/phpunit)
-%global phpunit %{_bindir}/phpunit
-%endif
-%if 0
-BuildRequires: php-composer(symfony/security) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/security) >= %{symfony_min_ver}
%else
-BuildRequires: php-composer(symfony/security-acl) < %{secacl_max_ver}
-BuildRequires: php-composer(symfony/security-acl) >= %{secacl_min_ver}
+BuildRequires: php-doctrine-cache >= %{cache_min_ver}
+BuildRequires: php-doctrine-inflector >= %{inflector_min_ver}
+BuildRequires: php-symfony-security-acl
+BuildRequires: php-symfony4-console
+BuildRequires: php-symfony4-doctrine-bridge
+BuildRequires: php-symfony4-finder
+BuildRequires: php-symfony4-framework-bundle
+BuildRequires: php-symfony4-validator
+BuildRequires: php-symfony4-yaml
%endif
+BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit7
## phpcompatinfo (computed from version 1.3.4)
BuildRequires: php-hash
BuildRequires: php-reflection
@@ -108,14 +98,11 @@ Requires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-compos
Requires: (php-composer(doctrine/inflector) >= %{inflector_min_ver} with php-composer(doctrine/inflector) < %{inflector_max_ver})
Requires: (php-composer(symfony/doctrine-bridge) >= %{symfony_min_ver} with php-composer(symfony/doctrine-bridge) < %{symfony_max_ver})
%else
-Requires: php-composer(doctrine/cache) < %{cache_max_ver}
-Requires: php-composer(doctrine/cache) >= %{cache_min_ver}
-Requires: php-composer(doctrine/inflector) < %{inflector_max_ver}
-Requires: php-composer(doctrine/inflector) >= %{inflector_min_ver}
-Requires: php-composer(symfony/doctrine-bridge) < %{symfony_max_ver}
-Requires: php-composer(symfony/doctrine-bridge) >= %{symfony_min_ver}
+Requires: php-doctrine-cache >= %{cache_min_ver}
+Requires: php-doctrine-inflector >= %{inflector_min_ver}
+Requires: php-symfony4-doctrine-bridge >= %{symfony_min_ver}
%endif
-# phpcompatinfo (computed from version 1.3.4)
+# phpcompatinfo (computed from version 1.4.0)
Requires: php-hash
Requires: php-reflection
Requires: php-spl
@@ -154,22 +141,20 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Bundle\\DoctrineCacheBundle\\', __DIR__);
-\Fedora\Autoloader\Dependencies::required(array(
+\Fedora\Autoloader\Dependencies::required([
'%{phpdir}/Doctrine/Common/Cache/autoload.php',
'%{phpdir}/Doctrine/Common/Inflector/autoload.php',
- array(
+ [
(getenv('RPM_SYMFONY_TREE')?:'%{phpdir}/Symfony4') . '/Bridge/Doctrine/autoload.php',
'%{phpdir}/Symfony3/Bridge/Doctrine/autoload.php',
- '%{phpdir}/Symfony/Bridge/Doctrine/autoload.php',
- ),
-));
+ ],
+]);
-\Fedora\Autoloader\Dependencies::optional(array(
- array(
- (getenv('RPM_SYMFONY_TREE')?:'%{phpdir}/Symfony3') . '/Component/Security/autoload.php',
+\Fedora\Autoloader\Dependencies::optional([
+ [
'%{phpdir}/Symfony/Component/Security/autoload.php',
- ),
-));
+ ],
+]);
AUTOLOAD
@@ -186,33 +171,24 @@ cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
require_once '%{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineCacheBundle/autoload.php';
-\Fedora\Autoloader\Dependencies::required(array(
- array(
+\Fedora\Autoloader\Dependencies::required([
+ [
'%{phpdir}/Symfony4/Bundle/FrameworkBundle/autoload.php',
'%{phpdir}/Symfony3/Bundle/FrameworkBundle/autoload.php',
- '%{phpdir}/Symfony/Bundle/FrameworkBundle/autoload.php',
- ),
- array(
+ ], [
'%{phpdir}/Symfony4/Component/Console/autoload.php',
'%{phpdir}/Symfony3/Component/Console/autoload.php',
- '%{phpdir}/Symfony/Component/Console/autoload.php',
- ),
- array(
+ ], [
'%{phpdir}/Symfony4/Component/Finder/autoload.php',
'%{phpdir}/Symfony3/Component/Finder/autoload.php',
- '%{phpdir}/Symfony/Component/Finder/autoload.php',
- ),
- array(
+ ], [
'%{phpdir}/Symfony4/Component/Validator/autoload.php',
'%{phpdir}/Symfony3/Component/Validator/autoload.php',
- '%{phpdir}/Symfony/Component/Validator/autoload.php',
- ),
- array(
+ ], [
'%{phpdir}/Symfony4/Component/Yaml/autoload.php',
'%{phpdir}/Symfony3/Component/Yaml/autoload.php',
- '%{phpdir}/Symfony/Component/Yaml/autoload.php',
- ),
-));
+ ],
+]);
BOOTSTRAP
: Modify PHPUnit config
@@ -229,7 +205,7 @@ popd
: Upstream tests
RETURN_CODE=0
-for cmdarg in "php %{phpunit}" php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose --bootstrap bootstrap.php \
@@ -253,6 +229,11 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 25 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- raise dependency on PHP 7.1
+- raise dependency on Symfony 3.4
+
* Sun Feb 23 2020 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.5-5
- Disable tests by default (for now) to fix FTBFS (RHBZ #1799868)