summaryrefslogtreecommitdiffstats
path: root/php-doctrine-doctrine-bundle2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-doctrine-bundle2.spec')
-rw-r--r--php-doctrine-doctrine-bundle2.spec28
1 files changed, 15 insertions, 13 deletions
diff --git a/php-doctrine-doctrine-bundle2.spec b/php-doctrine-doctrine-bundle2.spec
index 5f0287b..205208b 100644
--- a/php-doctrine-doctrine-bundle2.spec
+++ b/php-doctrine-doctrine-bundle2.spec
@@ -71,7 +71,7 @@
Name: php-%{composer_vendor}-%{composer_project}%{major}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Symfony Bundle for Doctrine
License: MIT
@@ -232,6 +232,17 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Bundle\\DoctrineBundle\\', __DIR__);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{phpdir}/Doctrine/ORM/autoload.php',
+ [
+ '%{phpdir}/Symfony4/Bundle/WebProfilerBundle/autoload.php',
+ '%{phpdir}/Symfony3/Bundle/WebProfilerBundle/autoload.php',
+ ], [
+ '%{phpdir}/Twig3/autoload.php',
+ '%{phpdir}/Twig2/autoload.php',
+ '%{phpdir}/Twig/autoload.php',
+ ],
+]);
\Fedora\Autoloader\Dependencies::required([
[
'%{phpdir}/Doctrine/DBAL3/autoload.php',
@@ -261,18 +272,6 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Symfony4/Component/DependencyInjection/autoload.php',
'%{phpdir}/Symfony3/Component/DependencyInjection/autoload.php',
]]);
-
-\Fedora\Autoloader\Dependencies::optional([
- '%{phpdir}/Doctrine/ORM/autoload.php',
- [
- '%{phpdir}/Symfony4/Bundle/WebProfilerBundle/autoload.php',
- '%{phpdir}/Symfony3/Bundle/WebProfilerBundle/autoload.php',
- ], [
- '%{phpdir}/Twig3/autoload.php',
- '%{phpdir}/Twig2/autoload.php',
- '%{phpdir}/Twig/autoload.php',
- ],
-]);
AUTOLOAD
@@ -327,6 +326,9 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 2.2.2-2
+- load ORM autoloader first to ensure proper DBAL version is used
+
* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 2.2.2-1
- update to 2.2.2