summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json11
-rw-r--r--php-doctrine-deprecations-pr27.patch35
-rw-r--r--php-doctrine-deprecations.spec34
3 files changed, 27 insertions, 53 deletions
diff --git a/composer.json b/composer.json
index 5cc7ac1..c79e38c 100644
--- a/composer.json
+++ b/composer.json
@@ -8,9 +8,9 @@
"php": "^7.1|^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^7.0|^8.0|^9.0",
- "psr/log": "^1.0",
- "doctrine/coding-standard": "^6.0|^7.0|^8.0"
+ "phpunit/phpunit": "^7.5|^8.5|^9.5",
+ "psr/log": "^1|^2|^3",
+ "doctrine/coding-standard": "^9"
},
"suggest": {
"psr/log": "Allows logging deprecations via PSR-3 logger implementation"
@@ -23,5 +23,10 @@
"DeprecationTests\\": "test_fixtures/src",
"Doctrine\\Foo\\": "test_fixtures/vendor/doctrine/foo"
}
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
}
}
diff --git a/php-doctrine-deprecations-pr27.patch b/php-doctrine-deprecations-pr27.patch
deleted file mode 100644
index 84a5690..0000000
--- a/php-doctrine-deprecations-pr27.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 41f562939513a3db98785289dde99a9765939cbd Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 31 Mar 2021 07:45:06 +0200
-Subject: [PATCH] Fix #26 add LICENSE file
-
----
- LICENSE | 19 +++++++++++++++++++
- 1 file changed, 19 insertions(+)
- create mode 100644 LICENSE
-
-diff --git a/LICENSE b/LICENSE
-new file mode 100644
-index 0000000..156905c
---- /dev/null
-+++ b/LICENSE
-@@ -0,0 +1,19 @@
-+Copyright (c) 2020-2021 Doctrine Project
-+
-+Permission is hereby granted, free of charge, to any person obtaining a copy of
-+this software and associated documentation files (the "Software"), to deal in
-+the Software without restriction, including without limitation the rights to
-+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
-+of the Software, and to permit persons to whom the Software is furnished to do
-+so, subject to the following conditions:
-+
-+The above copyright notice and this permission notice shall be included in all
-+copies or substantial portions of the Software.
-+
-+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-+SOFTWARE.
diff --git a/php-doctrine-deprecations.spec b/php-doctrine-deprecations.spec
index 3ac1ae7..bc30982 100644
--- a/php-doctrine-deprecations.spec
+++ b/php-doctrine-deprecations.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 9504165960a1f83cc1480e2be1dd0a0478561314
+%global gh_commit 0e2a4f1f8cdfc7a92ec3b01c9334898c806b30de
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project deprecations
@@ -21,8 +21,8 @@
%global ns_project Deprecations
Name: php-%{pk_vendor}-%{pk_project}
-Version: 0.5.3
-Release: 2%{?dist}
+Version: 1.0.0
+Release: 1%{?dist}
Summary: A small layer on top of trigger_error or PSR-3 logging
License: MIT
@@ -30,27 +30,23 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# Missing license file from
-# https://github.com/doctrine/deprecations/pull/27
-Patch0: %{name}-pr27.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json
# "require-dev": {
-# "phpunit/phpunit": "^7.0|^8.0|^9.0",
-# "psr/log": "^1.0",
-# "doctrine/coding-standard": "^6.0|^7.0|^8.0"
+# "phpunit/phpunit": "^7.5|^8.5|^9.5",
+# "psr/log": "^1|^2|^3",
+# "doctrine/coding-standard": "^9"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
+BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 4)
# remirepo:3
%else
BuildRequires: php-PsrLog
%endif
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.5
%endif
# From composer.json
@@ -62,7 +58,7 @@ BuildRequires: phpunit9
Requires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
+Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 4)
# remirepo:3
%else
Requires: php-PsrLog
@@ -95,7 +91,6 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -108,7 +103,11 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
cat << 'EOF' | tee -a lib/%{ns_vendor}/%{ns_project}/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{_datadir}/php/Psr/Log/autoload.php',
+ [
+ '%{_datadir}/php/Psr/Log3/autoload.php',
+ '%{_datadir}/php/Psr/Log2/autoload.php',
+ '%{_datadir}/php/Psr/Log/autoload.php',
+ ],
]);
EOF
@@ -158,6 +157,11 @@ exit $ret
%changelog
+* Tue May 3 2022 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+- allow psr/log 2 and 3
+- drop patch merged upstream
+
* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 0.5.3-2
- add LICENSE file copy/pasted from other doctrine project,
and from https://github.com/doctrine/deprecations/pull/27