summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-05 11:26:13 +0200
committerRemi Collet <remi@php.net>2023-06-05 11:26:13 +0200
commitef74e44b071848ee6e7c555a6a1cecf46d399d94 (patch)
treedacbd3efdcada45d1c51a35133cecf54bdc8b86e
parentc0e7cc3d13b1268af6f77f0fc66623269a1c1e89 (diff)
update to 1.1.1
-rw-r--r--composer.json20
-rw-r--r--php-doctrine-deprecations.spec20
2 files changed, 27 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index c79e38c..f8319f9 100644
--- a/composer.json
+++ b/composer.json
@@ -1,22 +1,28 @@
{
"name": "doctrine/deprecations",
- "type": "library",
"description": "A small layer on top of trigger_error(E_USER_DEPRECATED) or PSR-3 logging with options to disable all deprecations or selectively for packages.",
- "homepage": "https://www.doctrine-project.org/",
"license": "MIT",
+ "type": "library",
+ "homepage": "https://www.doctrine-project.org/",
"require": {
- "php": "^7.1|^8.0"
+ "php": "^7.1 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^7.5|^8.5|^9.5",
- "psr/log": "^1|^2|^3",
- "doctrine/coding-standard": "^9"
+ "doctrine/coding-standard": "^9",
+ "phpstan/phpstan": "1.4.10 || 1.10.15",
+ "phpstan/phpstan-phpunit": "^1.0",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+ "psalm/plugin-phpunit": "0.18.4",
+ "psr/log": "^1 || ^2 || ^3",
+ "vimeo/psalm": "4.30.0 || 5.12.0"
},
"suggest": {
"psr/log": "Allows logging deprecations via PSR-3 logger implementation"
},
"autoload": {
- "psr-4": {"Doctrine\\Deprecations\\": "lib/Doctrine/Deprecations"}
+ "psr-4": {
+ "Doctrine\\Deprecations\\": "lib/Doctrine/Deprecations"
+ }
},
"autoload-dev": {
"psr-4": {
diff --git a/php-doctrine-deprecations.spec b/php-doctrine-deprecations.spec
index 1297c4f..e719d98 100644
--- a/php-doctrine-deprecations.spec
+++ b/php-doctrine-deprecations.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 8cffffb2218e01f3b370bf763e00e81697725259
+%global gh_commit 612a3ee5ab0d5dd97b7cf3874a6efe24325efac3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project deprecations
@@ -21,7 +21,7 @@
%global ns_project Deprecations
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}
Summary: A small layer on top of triggeFr_error or PSR-3 logging
@@ -36,9 +36,13 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json
# "require-dev": {
-# "phpunit/phpunit": "^7.5|^8.5|^9.5",
-# "psr/log": "^1|^2|^3",
-# "doctrine/coding-standard": "^9"
+# "doctrine/coding-standard": "^9",
+# "phpstan/phpstan": "1.4.10 || 1.10.15",
+# "phpstan/phpstan-phpunit": "^1.0",
+# "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+# "psalm/plugin-phpunit": "0.18.4",
+# "psr/log": "^1 || ^2 || ^3",
+# "vimeo/psalm": "4.30.0 || 5.12.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 4)
@@ -136,7 +140,8 @@ EOF
ret=0
for cmd in php php80 php81 php82; do
if which $cmd; then
- $cmd %{_bindir}/phpunit9 \
+ $cmd -d auto_prepend_file=vendor/autoload.php \
+ %{_bindir}/phpunit9 \
--filter '^((?!(testDeprecationTrackByEnv)).)*$' \
--verbose || ret=1
fi
@@ -158,6 +163,9 @@ exit $ret
%changelog
+* Mon Jun 5 2023 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Tue May 30 2023 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0