summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-20 14:46:10 +0200
committerRemi Collet <remi@php.net>2023-04-20 14:46:10 +0200
commite3ebb820a98efb061a86995ae3706c6f0bdc9d82 (patch)
treebd8bb6944502e130d578ef6df0f6beb727522131
parent03b688d2975595a6fe5864d9e021a048685cc99c (diff)
add upstream patch for test suite with PHP 8.2 #2171642
-rw-r--r--php-doctrine-deprecations-php82.patch23
-rw-r--r--php-doctrine-deprecations.spec16
2 files changed, 34 insertions, 5 deletions
diff --git a/php-doctrine-deprecations-php82.patch b/php-doctrine-deprecations-php82.patch
new file mode 100644
index 0000000..ccc729b
--- /dev/null
+++ b/php-doctrine-deprecations-php82.patch
@@ -0,0 +1,23 @@
+From d0c1e0a2bcd9a0dd081198536a141ea29ba4f6e2 Mon Sep 17 00:00:00 2001
+From: DavidPrevot <david@tilapin.org>
+Date: Wed, 10 Aug 2022 19:02:01 +0200
+Subject: [PATCH] Be tolerant about line number pointer (#39)
+
+PHP 8.2 related fix.
+---
+ tests/Doctrine/Deprecations/DeprecationTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/Doctrine/Deprecations/DeprecationTest.php b/tests/Doctrine/Deprecations/DeprecationTest.php
+index e59c146..4d14a31 100644
+--- a/tests/Doctrine/Deprecations/DeprecationTest.php
++++ b/tests/Doctrine/Deprecations/DeprecationTest.php
+@@ -207,7 +207,7 @@ public function testDeprecationIfCalledFromOutside(): void
+ Deprecation::enableWithTriggerError();
+
+ $this->expectErrorHandler(
+- 'Bar::oldFunc() is deprecated, use Bar::newFunc() instead. (Bar.php:16 called by Foo.php:14, https://github.com/doctrine/foo, package doctrine/foo)',
++ 'Bar::oldFunc() is deprecated, use Bar::newFunc() instead. (Bar.php:%d called by Foo.php:14, https://github.com/doctrine/foo, package doctrine/foo)',
+ 'https://github.com/doctrine/foo'
+ );
+
diff --git a/php-doctrine-deprecations.spec b/php-doctrine-deprecations.spec
index bc30982..d4bf1e6 100644
--- a/php-doctrine-deprecations.spec
+++ b/php-doctrine-deprecations.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-doctrine-deprecations
#
-# Copyright (c) 2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2021-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -22,14 +22,16 @@
Name: php-%{pk_vendor}-%{pk_project}
Version: 1.0.0
-Release: 1%{?dist}
-Summary: A small layer on top of trigger_error or PSR-3 logging
+Release: 4%{?dist}
+Summary: A small layer on top of triggeFr_error or PSR-3 logging
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: %{name}-php82.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
@@ -91,6 +93,7 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch -P0 -p1
%build
@@ -134,7 +137,7 @@ cat << 'EOF' | tee -a vendor/autoload.php
EOF
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--verbose || ret=1
@@ -157,6 +160,9 @@ exit $ret
%changelog
+* Thu Apr 20 2023 Remi Collet <remi@remirepo.net> - 1.0.0-4
+- add upstream patch for test suite with PHP 8.2 #2171642
+
* Tue May 3 2022 Remi Collet <remi@remirepo.net> - 1.0.0-1
- update to 1.0.0
- allow psr/log 2 and 3