summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-doctrine-dbal3.spec9
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 6dda8c7..091b1fa 100644
--- a/composer.json
+++ b/composer.json
@@ -39,15 +39,15 @@
},
"require-dev": {
"doctrine/coding-standard": "9.0.0",
- "jetbrains/phpstorm-stubs": "2020.2",
- "phpstan/phpstan": "0.12.81",
- "phpstan/phpstan-strict-rules": "^0.12.2",
+ "jetbrains/phpstorm-stubs": "2021.1",
+ "phpstan/phpstan": "0.12.96",
+ "phpstan/phpstan-strict-rules": "^0.12.11",
"phpunit/phpunit": "9.5.5",
- "psalm/plugin-phpunit": "0.13.0",
+ "psalm/plugin-phpunit": "0.16.1",
"squizlabs/php_codesniffer": "3.6.0",
"symfony/cache": "^5.2|^6.0",
"symfony/console": "^2.0.5|^3.0|^4.0|^5.0|^6.0",
- "vimeo/psalm": "4.6.4"
+ "vimeo/psalm": "4.10.0"
},
"suggest": {
"symfony/console": "For helpful console commands such as SQL execution and import of files."
diff --git a/php-doctrine-dbal3.spec b/php-doctrine-dbal3.spec
index 3830ac7..71ead8b 100644
--- a/php-doctrine-dbal3.spec
+++ b/php-doctrine-dbal3.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 3.1.1
-%global github_commit 8e0fde2b90e3f61361013d1e928621beeea07bc0
+%global github_version 3.1.2
+%global github_commit 3ee2622b57370c786f531678f6641208747f7bfc
%global major 3
%global composer_vendor doctrine
@@ -228,7 +228,7 @@ SKIP="--filter '^((?!(testFetchAllKeyValueWithLimit)).)*$'"
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php73 php74 php80; do
+for PHP_EXEC in php php73 php74 php80 php81; do
rm -f /tmp/test_nesting.sqlite
if which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit9 \
@@ -253,6 +253,9 @@ exit $RETURN_CODE
%changelog
+* Mon Sep 13 2021 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
* Wed Jun 23 2021 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1
- allow symfony/console version 6