summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-04 09:42:23 +0200
committerRemi Collet <remi@remirepo.net>2021-10-04 09:42:23 +0200
commitce7831c688636cc39fca17d6509db39f89af3472 (patch)
tree5035bec16467c50852a8a6bc2565b228865c85bc
parentccb2cfd7a3469285a6c33525f94eae55ec6eaf91 (diff)
update to 3.1.3
-rw-r--r--composer.json7
-rw-r--r--php-doctrine-dbal3-bin.patch14
-rw-r--r--php-doctrine-dbal3.spec9
3 files changed, 14 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 091b1fa..013b6b8 100644
--- a/composer.json
+++ b/composer.json
@@ -40,9 +40,9 @@
"require-dev": {
"doctrine/coding-standard": "9.0.0",
"jetbrains/phpstorm-stubs": "2021.1",
- "phpstan/phpstan": "0.12.96",
+ "phpstan/phpstan": "0.12.99",
"phpstan/phpstan-strict-rules": "^0.12.11",
- "phpunit/phpunit": "9.5.5",
+ "phpunit/phpunit": "9.5.10",
"psalm/plugin-phpunit": "0.16.1",
"squizlabs/php_codesniffer": "3.6.0",
"symfony/cache": "^5.2|^6.0",
@@ -54,9 +54,6 @@
},
"bin": ["bin/doctrine-dbal"],
"config": {
- "platform": {
- "php": "7.3.0"
- },
"sort-packages": true
},
"autoload": {
diff --git a/php-doctrine-dbal3-bin.patch b/php-doctrine-dbal3-bin.patch
index 0f12483..2d92fcd 100644
--- a/php-doctrine-dbal3-bin.patch
+++ b/php-doctrine-dbal3-bin.patch
@@ -1,6 +1,6 @@
diff -up ./bin/doctrine-dbal.php.rpm ./bin/doctrine-dbal.php
---- ./bin/doctrine-dbal.php.rpm 2020-11-16 12:02:16.000000000 +0100
-+++ ./bin/doctrine-dbal.php 2020-11-16 12:21:56.895094784 +0100
+--- ./bin/doctrine-dbal.php.rpm 2021-10-04 09:39:41.000000000 +0200
++++ ./bin/doctrine-dbal.php 2021-10-04 09:40:19.300550825 +0200
@@ -1,25 +1,14 @@
+#!/usr/bin/env php
<?php
@@ -31,8 +31,8 @@ diff -up ./bin/doctrine-dbal.php.rpm ./bin/doctrine-dbal.php
$configFile = $directory . DIRECTORY_SEPARATOR . 'cli-config.php';
diff -up ./src/Tools/Console/ConsoleRunner.php.rpm ./src/Tools/Console/ConsoleRunner.php
---- ./src/Tools/Console/ConsoleRunner.php.rpm 2020-11-16 12:07:38.948729149 +0100
-+++ ./src/Tools/Console/ConsoleRunner.php 2020-11-16 12:08:24.685526402 +0100
+--- ./src/Tools/Console/ConsoleRunner.php.rpm 2021-10-04 09:39:41.000000000 +0200
++++ ./src/Tools/Console/ConsoleRunner.php 2021-10-04 09:41:02.034408249 +0200
@@ -5,7 +5,6 @@ namespace Doctrine\DBAL\Tools\Console;
use Doctrine\DBAL\Tools\Console\Command\ReservedWordsCommand;
use Doctrine\DBAL\Tools\Console\Command\RunSqlCommand;
@@ -41,13 +41,11 @@ diff -up ./src/Tools/Console/ConsoleRunner.php.rpm ./src/Tools/Console/ConsoleRu
use Symfony\Component\Console\Application;
use Symfony\Component\Console\Command\Command;
-@@ -25,9 +24,7 @@ class ConsoleRunner
+@@ -25,7 +24,7 @@ class ConsoleRunner
*/
public static function run(ConnectionProvider $connectionProvider, $commands = [])
{
-- $cli = new Application('Doctrine Command Line Interface', Versions::getVersion(
-- Versions::rootPackageName()
-- ));
+- $cli = new Application('Doctrine Command Line Interface', Versions::getVersion('doctrine/dbal'));
+ $cli = new Application('Doctrine Command Line Interface', '@VERSION@');
$cli->setCatchExceptions(true);
diff --git a/php-doctrine-dbal3.spec b/php-doctrine-dbal3.spec
index 35f87e6..18de29a 100644
--- a/php-doctrine-dbal3.spec
+++ b/php-doctrine-dbal3.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 3.1.2
-%global github_commit 3ee2622b57370c786f531678f6641208747f7bfc
+%global github_version 3.1.3
+%global github_commit 96b0053775a544b4a6ab47654dac0621be8b4cf8
%global major 3
%global composer_vendor doctrine
@@ -64,7 +64,7 @@ Patch0: %{name}-bin.patch
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.10
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
# remirepo:1
@@ -255,6 +255,9 @@ exit $RETURN_CODE
%changelog
+* Mon Oct 4 2021 Remi Collet <remi@remirepo.net> - 3.1.3-1
+- update to 3.1.3
+
* Mon Sep 13 2021 Remi Collet <remi@remirepo.net> - 3.1.2-1
- update to 3.1.2