summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-doctrine-dbal.spec9
2 files changed, 10 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index a1bf3f6..831f0a0 100644
--- a/composer.json
+++ b/composer.json
@@ -40,13 +40,14 @@
},
"require-dev": {
"doctrine/coding-standard": "9.0.0",
- "jetbrains/phpstorm-stubs": "2020.2",
- "phpstan/phpstan": "0.12.81",
+ "jetbrains/phpstorm-stubs": "2021.1",
+ "phpstan/phpstan": "0.12.96",
"phpunit/phpunit": "^7.5.20|^8.5|9.5.5",
+ "psalm/plugin-phpunit": "0.16.1",
"squizlabs/php_codesniffer": "3.6.0",
"symfony/cache": "^4.4",
"symfony/console": "^2.0.5|^3.0|^4.0|^5.0",
- "vimeo/psalm": "4.6.4"
+ "vimeo/psalm": "4.10.0"
},
"suggest": {
"symfony/console": "For helpful console commands such as SQL execution and import of files."
diff --git a/php-doctrine-dbal.spec b/php-doctrine-dbal.spec
index a782f43..1b5b8e0 100644
--- a/php-doctrine-dbal.spec
+++ b/php-doctrine-dbal.spec
@@ -16,8 +16,8 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 2.13.2
-%global github_commit 8dd39d2ead4409ce652fd4f02621060f009ea5e4
+%global github_version 2.13.3
+%global github_commit 0d7adf4cadfee6f70850e5b163e6cdd706417838
%global composer_vendor doctrine
%global composer_project dbal
@@ -225,7 +225,7 @@ SKIP="--filter '^((?!(testFetchAllKeyValueWithLimit)).)*$'"
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php73 php74 php80; do
+for PHP_EXEC in php php73 php74 php80 php81; do
rm -f /tmp/test_nesting.sqlite
if which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit9 \
@@ -251,6 +251,9 @@ exit $RETURN_CODE
%changelog
+* Mon Sep 13 2021 Remi Collet <remi@remirepo.net> - 2.13.3-1
+- update to 2.13.3
+
* Wed Jun 23 2021 Remi Collet <remi@remirepo.net> - 2.13.2-1
- update to 2.13.2
- allow doctrine/cache version 2