summaryrefslogtreecommitdiffstats
path: root/php-doctrine-dbal.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-21 12:19:51 +0200
committerRemi Collet <remi@remirepo.net>2020-09-21 12:19:51 +0200
commit124b43ef1246201ec2e73d4726ef0a9252a9407c (patch)
treebdd0af20e5689db405171c0076b1279cc8c02cd8 /php-doctrine-dbal.spec
parent91c94a8570c133c3f5357b0d0a86f20a6b7ec719 (diff)
update to 2.11.0
raise dependency on PHP 7.3 switch to phpunit9
Diffstat (limited to 'php-doctrine-dbal.spec')
-rw-r--r--php-doctrine-dbal.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/php-doctrine-dbal.spec b/php-doctrine-dbal.spec
index 9ccf4db..b5317e0 100644
--- a/php-doctrine-dbal.spec
+++ b/php-doctrine-dbal.spec
@@ -13,14 +13,14 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 2.10.4
-%global github_commit 47433196b6390d14409a33885ee42b6208160643
+%global github_version 2.11.0
+%global github_commit 0d4e1a8b29dd987704842f0465aded378f441dca
%global composer_vendor doctrine
%global composer_project dbal
-# "php": "^7.2"
-%global php_min_ver 7.2
+# "php": "^7.3"
+%global php_min_ver 7.3
# "doctrine/cache": "^1.0"
%global doctrine_cache_min_ver 1.0
%global doctrine_cache_max_ver 2
@@ -56,7 +56,7 @@ Patch0: %{name}-bin.patch
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: phpunit8 >= 8.5.5
+BuildRequires: phpunit9 >= 9.3
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
# remirepo:1
@@ -193,11 +193,12 @@ require_once '%{buildroot}/%{phpdir}/Doctrine/DBAL/autoload.php';
BOOTSTRAP
: Upstream tests
+# TODO php 8 (Doctrine\DBAL\Driver\PDOConnection::query() must be compatible with PDO::query)
RETURN_CODE=0
-for PHP_EXEC in php php72 php73 php74; do
+for PHP_EXEC in php php73 php74; do
rm -f /tmp/test_nesting.sqlite
if which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit8 \
+ $PHP_EXEC %{_bindir}/phpunit9 \
--bootstrap bs.php \
--verbose || RETURN_CODE=1
fi
@@ -218,6 +219,11 @@ exit $RETURN_CODE
%changelog
+* Mon Sep 21 2020 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Mon Sep 14 2020 Remi Collet <remi@remirepo.net> - 2.10.4-1
- update to 2.10.4