summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-02 15:08:42 +0200
committerRemi Collet <remi@remirepo.net>2020-09-02 15:08:42 +0200
commit7e6281de35a5a351cd95fdd054e0104f4b3d376a (patch)
treef31801882b4722e783299f6d2e72a862bc72a84c
parentc8de59ebe967db61928fb6aa50b225257a02476d (diff)
update to 2.10.3
-rw-r--r--composer.json16
-rw-r--r--php-doctrine-dbal.spec15
2 files changed, 20 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 4a426e4..0c61fc4 100644
--- a/composer.json
+++ b/composer.json
@@ -38,18 +38,24 @@
"doctrine/event-manager": "^1.0"
},
"require-dev": {
- "doctrine/coding-standard": "^6.0",
+ "doctrine/coding-standard": "^8.1",
"jetbrains/phpstorm-stubs": "^2019.1",
- "phpstan/phpstan": "^0.11.3",
- "phpunit/phpunit": "^8.4.1",
- "symfony/console": "^2.0.5|^3.0|^4.0|^5.0"
+ "nikic/php-parser": "^4.4",
+ "phpstan/phpstan": "^0.12.40",
+ "phpunit/phpunit": "^8.5.5",
+ "psalm/plugin-phpunit": "^0.10.0",
+ "symfony/console": "^2.0.5|^3.0|^4.0|^5.0",
+ "vimeo/psalm": "^3.14.2"
},
"suggest": {
"symfony/console": "For helpful console commands such as SQL execution and import of files."
},
"bin": ["bin/doctrine-dbal"],
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.2.0"
+ }
},
"autoload": {
"psr-4": { "Doctrine\\DBAL\\": "lib/Doctrine/DBAL" }
diff --git a/php-doctrine-dbal.spec b/php-doctrine-dbal.spec
index 292daf4..fd00302 100644
--- a/php-doctrine-dbal.spec
+++ b/php-doctrine-dbal.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 2.10.2
-%global github_commit aab745e7b6b2de3b47019da81e7225e14dcfdac8
+%global github_version 2.10.3
+%global github_commit 03ca23afc2ee062f5d3e32426ad37c34a4770dcf
%global composer_vendor doctrine
%global composer_project dbal
@@ -34,7 +34,7 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
@@ -55,8 +55,8 @@ Patch0: %{name}-bin.patch
BuildArch: noarch
# Tests
-%if %{with_tests}
-BuildRequires: phpunit8 >= 8.4.1
+%if %{with tests}
+BuildRequires: phpunit8 >= 8.5.5
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
# remirepo:1
@@ -182,7 +182,7 @@ install -pm 0755 bin/doctrine-dbal.php %{buildroot}/%{_bindir}/doctrine-dbal
%check
-%if %{with_tests}
+%if %{with tests}
cat > bs.php <<'BOOTSTRAP'
<?php
require_once '%{buildroot}/%{phpdir}/Doctrine/DBAL/autoload.php';
@@ -218,6 +218,9 @@ exit $RETURN_CODE
%changelog
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 2.10.3-1
+- update to 2.10.3
+
* Tue Apr 21 2020 Remi Collet <remi@remirepo.net> - 2.10.2-1
- update to 2.10.2