summaryrefslogtreecommitdiffstats
path: root/php-doctrine-datafixtures.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-21 09:27:53 +0100
committerRemi Collet <remi@php.net>2022-01-21 09:27:53 +0100
commit82081d24f8ef3baca5a562730a1e79aa6b11bf48 (patch)
tree21128269db6fa363661a64863b2b04e2b7d54249 /php-doctrine-datafixtures.spec
parent181327f5416952403607f1674b407e39431afab8 (diff)
update to 1.5.2
drop patch merged upstream
Diffstat (limited to 'php-doctrine-datafixtures.spec')
-rw-r--r--php-doctrine-datafixtures.spec20
1 files changed, 11 insertions, 9 deletions
diff --git a/php-doctrine-datafixtures.spec b/php-doctrine-datafixtures.spec
index 45e3230..cab4c93 100644
--- a/php-doctrine-datafixtures.spec
+++ b/php-doctrine-datafixtures.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-datafixtures
#
-# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name data-fixtures
-%global github_version 1.5.1
-%global github_commit f18adf13f6c81c67a88360dca359ad474523f8e3
+%global github_version 1.5.2
+%global github_commit 51c1890e8c5467c421c7cab4579f059ebf720278
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor doctrine
@@ -27,8 +27,8 @@
# "doctrine/orm": "^2.7.0"
%global doctrine_orm_min_ver 2.7.0
%global doctrine_orm_max_ver 3.0
-# "doctrine/dbal": "^2.5.4 || ^3.0"
-%global doctrine_dbal_min_ver 2.5.4
+# "doctrine/dbal": "^2.13 || ^3.0"
+%global doctrine_dbal_min_ver 2.13
%global doctrine_dbal_max_ver 4
# "doctrine/persistence": "^1.3.3|^2.0"
%global doctrine_pers_min_ver 1.3.3
@@ -50,8 +50,6 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_short}.tgz
Source1: makesrc.sh
-Patch0: %{name}-dbal3.patch
-
BuildArch: noarch
# Tests
%if %{with tests}
@@ -122,7 +120,7 @@ Autoloader: %{phpdir}/Doctrine/Common/DataFixtures/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
+
%build
: Create autoloader
@@ -178,7 +176,7 @@ rm tests/Doctrine/Tests/Common/DataFixtures/Executor/PHPCRExecutorTest.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php73 php74 php80 php81; do
+for PHP_EXEC in "" php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit8 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -201,6 +199,10 @@ exit $RETURN_CODE
%changelog
+* Fri Jan 21 2022 Remi Collet <remi@remirepo.net> - 1.5.2-1
+- update to 1.5.2
+- drop patch merged upstream
+
* Tue Oct 5 2021 Remi Collet <remi@remirepo.net> - 1.5.1-1
- update to 1.5.1
- add patch for test suite with doctrine/dbal v3 from