summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-25 10:30:32 +0100
committerRemi Collet <remi@remirepo.net>2021-01-25 10:30:32 +0100
commitf273bfb1b60865dfdd897b5effc465678b08102c (patch)
tree837c2f3bdaba7282bea9820bdcf94d6202d6f428
parentf7ce99d714446535076bb6cb12345d833b69c6fe (diff)
update to 1.5.0HEADmaster
-rw-r--r--.gitignore2
-rw-r--r--composer.json22
-rw-r--r--php-doctrine-datafixtures.spec59
3 files changed, 45 insertions, 38 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index aff8fa2..9ec9b4b 100644
--- a/composer.json
+++ b/composer.json
@@ -15,37 +15,29 @@
],
"require": {
"php": "^7.2 || ^8.0",
- "doctrine/common": "^2.11",
- "doctrine/persistence": "^1.3.3"
+ "doctrine/common": "^2.13|^3.0",
+ "doctrine/persistence": "^1.3.3|^2.0"
},
"conflict": {
"doctrine/phpcr-odm": "<1.3.0"
},
"require-dev": {
- "alcaeus/mongo-php-adapter": "^1.1",
- "doctrine/coding-standard": "^6.0",
+ "ext-sqlite3": "*",
+ "doctrine/coding-standard": "^8.2",
"doctrine/dbal": "^2.5.4",
- "doctrine/mongodb-odm": "^1.3.0",
+ "doctrine/mongodb-odm": "^1.3.0 || ^2.0.0",
"doctrine/orm": "^2.7.0",
- "phpunit/phpunit": "^7.0"
+ "phpunit/phpunit": "^8.0"
},
"suggest": {
- "alcaeus/mongo-php-adapter": "For using MongoDB ODM with PHP 7",
+ "alcaeus/mongo-php-adapter": "For using MongoDB ODM 1.3 with PHP 7 (deprecated)",
"doctrine/mongodb-odm": "For loading MongoDB ODM fixtures",
"doctrine/orm": "For loading ORM fixtures",
"doctrine/phpcr-odm": "For loading PHPCR ODM fixtures"
},
"config": {
- "platform": {
- "ext-mongo": "1.6.16"
- },
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "1.4.x-dev"
- }
- },
"autoload": {
"psr-4": {
"Doctrine\\Common\\DataFixtures\\": "lib/Doctrine/Common/DataFixtures"
diff --git a/php-doctrine-datafixtures.spec b/php-doctrine-datafixtures.spec
index aa40af5..0c88bc4 100644
--- a/php-doctrine-datafixtures.spec
+++ b/php-doctrine-datafixtures.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name data-fixtures
-%global github_version 1.4.3
-%global github_commit 7ebac50901eb4516816ac39100dba1759d843943
+%global github_version 1.5.0
+%global github_commit 51d3d4880d28951fff42a635a2389f8c63baddc5
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor doctrine
@@ -21,24 +21,21 @@
# "php": "^7.2 || ^8.0"
%global php_min_ver 7.2
-# "doctrine/common": "~2.11"
-%global doctrine_common_min_ver 2.11
-%global doctrine_common_max_ver 3.0
+# "doctrine/common": "~2.13|^3.0"
+%global doctrine_common_min_ver 2.13
+%global doctrine_common_max_ver 4
# "doctrine/orm": "^2.7.0"
%global doctrine_orm_min_ver 2.7.0
%global doctrine_orm_max_ver 3.0
# "doctrine/dbal": "^2.5.4"
%global doctrine_dbal_min_ver 2.5.4
%global doctrine_dbal_max_ver 3.0
-# "doctrine/persistence": "^1.3.3"
+# "doctrine/persistence": "^1.3.3|^2.0"
%global doctrine_pers_min_ver 1.3.3
-%global doctrine_pers_max_ver 2
-# "alcaeus/mongo-php-adapter": "^1.1"
-%global alcaeus_mongo_min_ver 1.1
-%global alcaeus_mongo_max_ver 2
+%global doctrine_pers_max_ver 3
# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -55,16 +52,18 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
+%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-sqlite3
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires:(php-composer(doctrine/common) >= %{doctrine_common_min_ver} with php-composer(doctrine/common) < %{doctrine_common_max_ver})
BuildRequires:(php-composer(doctrine/orm) >= %{doctrine_orm_min_ver} with php-composer(doctrine/orm) < %{doctrine_orm_max_ver})
BuildRequires:(php-composer(doctrine/dbal) >= %{doctrine_dbal_min_ver} with php-composer(doctrine/dbal) < %{doctrine_dbal_max_ver})
BuildRequires:(php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} with php-composer(doctrine/persistence) < %{doctrine_pers_max_ver})
-BuildRequires:(php-composer(alcaeus/mongo-php-adapter) >= %{alcaeus_mongo_min_ver} with php-composer(alcaeus/mongo-php-adapter) < %{alcaeus_mongo_max_ver})
-# missing doctrine/mongodb-odm
+# missing doctrine/mongodb-odm ^1.3.0 || ^2.0.0
+# remirepo:10
%else
BuildRequires: php-composer(doctrine/common) < %{doctrine_common_max_ver}
BuildRequires: php-composer(doctrine/common) >= %{doctrine_common_min_ver}
@@ -74,10 +73,8 @@ BuildRequires: php-composer(doctrine/dbal) < %{doctrine_dbal_max_ver}
BuildRequires: php-composer(doctrine/dbal) >= %{doctrine_dbal_min_ver}
BuildRequires: php-composer(doctrine/persistence) < %{doctrine_pers_max_ver}
BuildRequires: php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver}
-BuildRequires: php-composer(alcaeus/mongo-php-adapter) < %{alcaeus_mongo_max_ver}
-BuildRequires: php-composer(alcaeus/mongo-php-adapter) >= %{alcaeus_mongo_min_ver}
%endif
-BuildRequires: phpunit7
+BuildRequires: phpunit8
## phpcompatinfo (computed from version 1.0.2)
BuildRequires: php-json
BuildRequires: php-reflection
@@ -88,12 +85,14 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/common) >= %{doctrine_common_min_ver} with php-composer(doctrine/common) < %{doctrine_common_max_ver})
Requires: (php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} with php-composer(doctrine/persistence) < %{doctrine_pers_max_ver})
-# composer.json: optional
+# composer.json: optional and deprecated
Suggests: php-composer(alcaeus/mongo-php-adapter)
# missing option doctrine/mongodb-odm
+# remirepo:6
%else
Requires: php-composer(doctrine/common) < %{doctrine_common_max_ver}
Requires: php-composer(doctrine/common) >= %{doctrine_common_min_ver}
@@ -136,8 +135,13 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Common\\DataFixtures\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
- '%{phpdir}/Doctrine/Common/autoload.php',
- '%{phpdir}/Doctrine/Persistence/autoload.php',
+ [
+ '%{phpdir}/Doctrine/Common3/autoload.php',
+ '%{phpdir}/Doctrine/Common/autoload.php',
+ ], [
+ '%{phpdir}/Doctrine/Persistence2/autoload.php',
+ '%{phpdir}/Doctrine/Persistence/autoload.php',
+ ]
]);
\Fedora\Autoloader\Dependencies::optional([
@@ -153,7 +157,7 @@ cp -rp lib/* %{buildroot}%{phpdir}/
%check
-%if %{with_tests}
+%if %{with tests}
: Create tests bootstrap
cat << 'BOOTSTRAP' | tee bootstrap.php
<?php
@@ -166,9 +170,9 @@ rm tests/Doctrine/Tests/Common/DataFixtures/Executor/PHPCRExecutorTest.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php72 php73 php74; do
+for PHP_EXEC in "" php72 php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit7 --verbose --bootstrap bootstrap.php \
+ $PHP_EXEC %{_bindir}/phpunit8 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -179,6 +183,7 @@ exit $RETURN_CODE
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -188,6 +193,14 @@ exit $RETURN_CODE
%changelog
+* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
+* Tue Sep 1 2020 Remi Collet <remi@remirepo.net> - 1.4.4-1
+- update to 1.4.4
+- raise dependency on doctrine/common 2.13 and allow v3
+- allow doctrine/persistence v2
+
* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.4.3-1
- update to 1.4.3 (no change)