summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-doctrine-common3.spec12
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index c85a3ca..34a67fc 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
"doctrine/persistence": "^2.0"
},
"require-dev": {
- "phpstan/phpstan": "^1.2.0",
+ "phpstan/phpstan": "^1.4.1",
"phpstan/phpstan-phpunit": "^1",
"phpunit/phpunit": "^7.5.20 || ^8.5 || ^9.0",
"doctrine/coding-standard": "^9.0",
@@ -39,5 +39,11 @@
"psr-4": {
"Doctrine\\Tests\\": "tests/Doctrine/Tests"
}
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true,
+ "composer/package-versions-deprecated": true
+ }
}
}
diff --git a/php-doctrine-common3.spec b/php-doctrine-common3.spec
index 272ef5c..a96e5b7 100644
--- a/php-doctrine-common3.spec
+++ b/php-doctrine-common3.spec
@@ -10,8 +10,8 @@
%global github_owner doctrine
%global github_name common
-%global github_version 3.2.1
-%global github_commit e927fc2410c8723d053b8032e591cdff76587cdb
+%global github_version 3.2.2
+%global github_commit 295082d3750987065912816a9d536c2df735f637
%global major 3
%global composer_vendor doctrine
@@ -59,13 +59,8 @@ BuildRequires: (php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} w
%else
BuildRequires: php-doctrine-persistence2
%endif
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.0
-%else
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8 >= 8.5
-%endif
## phpcompatinfo (computed from version 3.0.0)
BuildRequires: php-reflection
BuildRequires: php-date
@@ -156,6 +151,9 @@ exit $RETURN_CODE
%changelog
+* Wed Feb 2 2022 Remi Collet <remi@remirepo.net> - 3.2.2-1
+- update to 3.2.2
+
* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 3.2.1-1
- update to 3.2.1